4 Replies
      Latest reply on Sep 11, 2019 1:00 AM by eskimo
      JanC Level 1 Level 1 (0 points)

        Hi,

        I downloaded the latest XCode beta 7 but the playground are unusable. XCode stops responding when I open ant .playground file.

         

         

        Steps to reproduce:

        - Download XCode 11 beta

        - Create a new playground

         

         

        Is this a known issue? Are there any workarounds?

        cheers,

        Jan

        • Re: XCode 11 Beta 7 Playground not responding
          eskimo Apple Staff Apple Staff (11,835 points)

          What type of playground are you creating?  In my experience, iOS playgrounds tend to be a lot more troublesome than macOS ones, especially with pre-release builds.

          Share and Enjoy

          Quinn “The Eskimo!”
          Apple Developer Relations, Developer Technical Support, Core OS/Hardware
          let myEmail = "eskimo" + "1" + "@apple.com"

            • Re: XCode 11 Beta 7 Playground not responding
              JanC Level 1 Level 1 (0 points)

              Hi,

              I'm using an iOS Playground. When I create a new macOS playground, it fails compiling with the error

               

               

               

               

              error: Couldn't lookup symbols:

                _playground_log_hidden

                _playground_log_hidden

               

               

               

              Anyway, I'll wait for the Golden Master before using XC 11

               

               

              ps: I attached a screenshot to this post but it does not seem to appear

                • Re: XCode 11 Beta 7 Playground not responding
                  eskimo Apple Staff Apple Staff (11,835 points)

                  When I create a new macOS playground, it fails compiling with the error

                  error: Couldn't lookup symbols:
                  _playground_log_hidden
                  _playground_log_hidden

                  Yeah, I saw that too )-:

                  As I mentioned, macOS playgrounds tend to be more reliable, so it’s ironic that iOS playgrounds are working for me in Xcode 11.0b7.

                  Anyway, I'll wait for the Golden Master before using XC 11

                  Probably for the best, assuming you don’t need to Xcode 11 features.

                  I attached a screenshot to this post but it does not seem to appear

                  Indeed.  This is a well-known limitation of DevForums.  If you need to share a screen shot, your best option is to put it on an image sharing service and then post a link.  The link will require moderation, but that’s generally not a problem.

                  Share and Enjoy

                  Quinn “The Eskimo!”
                  Apple Developer Relations, Developer Technical Support, Core OS/Hardware
                  let myEmail = "eskimo" + "1" + "@apple.com"

                    • Re: XCode 11 Beta 7 Playground not responding
                      eskimo Apple Staff Apple Staff (11,835 points)

                      Yeah, I saw that too )-:

                      I’m pleased to report that the _playground_log_hidden problem is fixed in Xcode 11 GM Seed (at least for me :-).

                      Share and Enjoy

                      Quinn “The Eskimo!”
                      Apple Developer Relations, Developer Technical Support, Core OS/Hardware
                      let myEmail = "eskimo" + "1" + "@apple.com"