9 Replies
      Latest reply on Oct 29, 2019 10:11 AM by KMT
      xTeal Level 1 Level 1 (0 points)

             I have downloaded and installed Xcode in the past and I didn't have any problems with it until I uninstalled it, came back a few months or so later, and reinstalled it today.

             I redownloaded and reinstalled Xcode 9.2 but that always crashes on startup. There is a crash but I'll simplify what it says.

        The file xcode/Xcode.app/Contents/PlugIns/IDEInterfaceBuilderCocoaTouchIntegration.framework is missing

        System Integrity Protection: enabled
        
        
        Crashed Thread:        0  Dispatch queue: com.apple.main-thread
        
        
        Exception Type:        EXC_CRASH (SIGABRT)
        Exception Codes:       0x0000000000000000, 0x0000000000000000
        Exception Note:        EXC_CORPSE_NOTIFY
        
        
        Application Specific Information:
        ProductBuildVersion: 9B55
        
        OS Version:            Mac OS X 10.12.6
        Report Version:        12

        I have downloaded XCode 9.2 & 9.1 from https://developer.apple.com/download/more/

         

        I'm not sure why when I open up the .xip file, XCode is created without the .framework file. It was fine when I downloaded it in the past, perhaps I got rid of the wrong files when I attempted to uninstall XCode 9.2, forgot the directories for what I deleted though, I remember I deleted ~/library/Developer/
        Should I try using Xcode for 10.13.6 on 10.12.6 and edit one of the files so it takes in macOS 10.12.6 instead of 13?

        • Re: Xcode 9.1 & 9.2 crash on startup from a missing file
          xTeal Level 1 Level 1 (0 points)

          I just realized that the actual damaged file is

          /xcode/Xcode.app/Contents/PlugIns/IDEInterfaceBuilderCocoaTouchIntegration.framework/IDEInterfaceBuilderCocoaTouchIntegration

          or the IDEInterfaceBuilderCocoaTouchIntegration under the IDEInterfaceBuilderCocoaTouchIntegration.framework file.

          I went to go check and yes, the .framework file is existent and so is the IDEInterfaceBuilderCocoaTouchIntegration file which is an alias file. So I'm concluding that the file could be damaged. Won't bother to try on XCode 9 because that'll take too much time out of my day downloading and unzipping 5 gb files.


          UPDATE

          According to console, it says the library

          /Library/Developer/PrivateFrameworks/CoreSimulator.framework/Versions/A/CoreSimulator

          is not loaded. I checked xcode and directory doesn't exist, i inputted it into finder, doesn't exist, and I tried ~/Library/Developer/PrivateFrameworks/CoreSimulator.framework/Versions/A/CoreSimulator

          as well and got nothing.

          • Re: Xcode 9.1 & 9.2 crash on startup from a damaged(?) file
            auroraz7 Level 1 Level 1 (0 points)

            I have the same problem, and am getting the exact same error message. I prefer to stick with Sierra 10.12.6, for a variety of reasons. So, I figured I'd download and reinstall XCode 9.2, which is the version that is best calibrated to my computer's operating system.

             

            However, when I download Xcode_9.2.xip, I can't even open it: ArchiveUtility informs me that it is not an Apple product (note: I downloaded it from the Apple Developer "more downloads" site). I am stymied.

             

            I am using a MacBook Pro, 9,1. 2.6 GHz Intel Core i7, 1TB Solid State hard drive, 16GB RAM.

             

            All ideas will be greatly appreciated.

              • Re: Xcode 9.1 & 9.2 crash on startup from a damaged(?) file
                KMT Level 9 Level 9 (15,425 points)

                     >: ArchiveUtility informs me that it is not an Apple product

                 

                It is apparently an expired Apple certificate issue. Might try resetting the date on your mac to before Oct. 24, 2019, long enough to try unpacking/installing again.

                 

                Still no joy, you may want to start your own thread so you can better track, close if solved, etc.

                 

                Good luck.