6 Replies
      Latest reply on Sep 12, 2019 11:57 AM by dwarfland
      dwarfland Level 1 Level 1 (0 points)

        Hi.

         

        i'm updatign one of my apps to iOS 13 and Dark Mode, but somehow i cannot get the launch xib to behave. The original xib was white background with black text and images. I've changed it to use the new system colors, and it ooks fine in Xcode when in toggle the appearance to dark — but when my app launches on an actual iPhone with iOS 13(.1) Beta with Dark Mode active, while the rest of the app respects dark mode perfectly fine, the launch screen always comes up white.

         

        What could i be missing?

         

        thanx,

        marc

        • Re: Launch .xib and Dark Mode?
          Claude31 Level 8 Level 8 (6,515 points)

          Did you update the app or completely remove it ?

           

          You should try remove first, (launch screen are cached and not overriden by the upfate).

            • Re: Launch .xib and Dark Mode?
              widemos Level 1 Level 1 (0 points)

              I'm, experiencing the same behaviour. Deleting the app doesn't help.

               

              As stated in this thread https://forums.developer.apple.com/thread/120799, if the app's target is iOS 13.0, the launch screen works normally but, if it's 12 or lower (I'm in 9.3 but tried 10 and 12 already) the light mode launchscreen works but the dark mode one shows only a white background.

               

              Time to wait for GM build of Xcode I think, this must be in the bug pipeline already.

              • Re: Launch .xib and Dark Mode?
                dwarfland Level 1 Level 1 (0 points)

                > Did you update the app or completely remove it ?

                 

                i'm installing the app via TestFlight. Did delete and reinstall it a few times last week while testing other issues (long post fixing the launch screen), so i don't tonk that's it, but i'll retry.

                 

                Curious though that installing an update would not invalidate the launch screen. That would affect all real users as well, surely? What f an app update wants to *chnage* the laumch screen? Seems like a weird policy, if true.

              • Re: Launch .xib and Dark Mode?
                dwarfland Level 1 Level 1 (0 points)

                Oddly, i'm just noticing, i have a nother view in the app thaty also doesn thonor dark mode properly. Until i just updated the xib to latest Xcode, it would show a white backghround, but the text labels would ("correctly") be white as well, and thius invisible. (both background and label color used the new values, SystemBackground, LabelColor). With the very latest now (some properties in the xib seems to have gotten renamed), it now shows fully as light mode again (white background, black text), even tbough the rest of the app i dark.

                 

                This view too looks fine for Dark Mode in the designer.

                 

                FTR, most of my app does not use xibs/storyboards, but manually instantiated table viewes. The only other xib based view is a Map, and that one shows dark correctly. very weird.

                 

                Am i missing a setting in the xibs themselves to enable them for dark mode of iOS13? (they are set to "Open in Latest Xcode (10.0), Build for Deployment target)" (not sure why it says "Latest Xcode" is 10;  11 shows in the dropdown as option as well...

                  • Re: Launch .xib and Dark Mode?
                    dwarfland Level 1 Level 1 (0 points)

                    It gets freakier. i just checked my other iOS 13 tets device, an iPad, which still had an earlier beta build of my app — both screens showed in dark mode just fine. Updated to my latest build, and now both viewes show their light-mode counterpart. The Launch view had been completely untouhced since i first added Dark Mode support; looks like just having been rebuilt with a newer Xcode beta broke it, maybe?

                  • Re: Launch .xib and Dark Mode?
                    dwarfland Level 1 Level 1 (0 points)

                    This one looks fixed for me after rebuilding my app with GM. Phew.