3 Replies
      Latest reply on Sep 3, 2019 5:14 PM by Archerli22
      Archerli22 Level 1 Level 1 (0 points)

        Hi there,

        I am facing this critical issue for almost half years already. I am putting all the crash details here for your debugging.

        1. The app works fine either install from cable or Testflight at the beginning but after it runs a while (no specific time period, could be 1 day, could be 1 week), when I open the app, it will stay on the launch screen and FREEZE there.
        2. Once the "FREEZE" comes, not only the app crash, iOS will behave weird:
          1. After long-pressing the app icon, all app icon wiggles like normal but I cannot delete ANY app in my phone. Not only my app but also all the apps. Even I tried to remove the app from Setting --> General --> storage --> delete the app, the app icon is still there but if I am clicking on that, it will not show the launch screen but a black screen instead
          2. If I tried to turn off the screen, there are supposed to be three sliding bars showing (slide to power off, emergency SOS, Medical Emergency Card) parallelly, but two of them overlapped each other.
        3. I tried to debug the crash by connecting the phone and my laptop. the console log shows:
          1. [DYMTLInitPlatform] platform initialization successful
          2. after I touch the screen, the log will show: XPC connection interrupted
        4. If I restart my phone, everything will work well, my app will open properly, but after sometimes it will go back to the same crash again.

         

        I have struggled with this issue for a long time, most of the result from google indicates that my app is terminating by the system because of memory issues, and I know there is something wrong with my app. However, how my app will affect the entire iOS system?

        Please let me know if anyone has anything guessing or any suggestion on that.