2 Replies
      Latest reply on Aug 28, 2019 7:56 AM by part12studios
      part12studios Level 1 Level 1 (0 points)

        Hi there,

         

        I have an app in xcode and i can do builds with a direct iOS device (a physical iPhone 6s Plus) and xcode builds the app and pushes it to the device..  awesome.

         

        however the next step for me is to get it on testflight and to do this my understanding is that i must go to product / archive to build an uploadable file.  I am told to select "generic ios device" when doing this so I do but get the error.

         

        "Build system information

        error: (my app) has conflicting provisioning settings. (my app) is automatically signed for development, but a conflicting code signing identity iPhone Distribution has been manually specified. Set the code signing identity value to "iPhone Developer" in the build settings editor, or switch to manual signing in the project editor. (in target '(my app')"

         

        everything i try to tweak in there doesn't seem to matter.  Anyone dealt with this before? 

        • Re: Product / Archive / Generic iOS Device build fails
          KMT Level 9 Level 9 (14,635 points)

             > a conflicting code signing identity iPhone Distribution has been manually specified.

           

          Was that a conscious effort, or does that come as a surprise?

           

          Remember, you can't archive if:

          - a simulator is selected instead of a device*

          - there is an error when building*

          - you haven't finished the 'Prepare for Submission’ stage for that app in App Store Connect

            - See: https://developer.apple.com/library/ios/documentation/LanguagesUtilities/Conceptual/iTunesConnect_Guide/Chapters/ChangingAppStatus.html

          - you've recently renewed your (required) apple developer account, and not yet updated the provisions to reflect that activity

           

          * You must have at least one device registered in the Member Center, but it doesn’t have to be connected to your Mac/Xcode when building, in which case select ‘generic iOS/tvOS device'


          - - - If this is just about testing to a device and you're getting a message that Xcode can't archive, try deleting all older versions of that app on the target device first

           

          Also see TN2215: Why is the Archive menu item grayed out in Xcode ?

           

               >everything i try to tweak in there doesn't seem to matter

           

          Be sure to perform an option-clean build folder via the Product menu after juggling those settings.

           

          BTW, thanks for starting your own thread & good luck.

            • Re: Product / Archive / Generic iOS Device build fails
              part12studios Level 1 Level 1 (0 points)

              conflicting with what?  to do signing i have to select my team.  i am signed in as the managing email / account..    my team is Part12 Studios.  All other options are no good, they are other companies I have done stuff for.  I don't think the Caleb Garner (personal team) is right.  The only one that doesn't result in some kind of error is the "Part12 Studios" option seems right since that's the account i'm building under..

               

              https://drive.google.com/open?id=19H18jp_qCKElNYCPl_ao4S7kF_RfoUsO

               

              https://drive.google.com/open?id=1UkwT2hc5O0ixShj02bZ0I2bgY2BwQ3DC

               

              when i try to give it what it asks for it doesn't seem to like the files.  movie provisoins are all i can import and none of those seem to give it what it wants..

               

              https://drive.google.com/open?id=1HL7L0puj4obDDlO6dvIQynL0WKlHBhft

               

              it just seems completely illogical and convoluted by using a mish mash of overlapping terminologies..  "app doesn't include signing certificate.. bla bla..  LHG7W4C55M..

               

              but then I export the iPhone Distribution LHG7W4C55M as a cert or a .p12 and i click the "import profile" and certs and p12s are grayed out.  thinking this is what it's asking for.  they are grayed out files.  the only files it will accept are .mobileprovisioning files which I have both distribution and adhoc neither of which it accepts and they were paired with the cert that was associated with LHG7W4C55M

               

               

              fumbling around I got this error as well some how..  and while it sounds like it's offering specific suggestions.. its more convoluted terminilogies that I can't really identify..

               

              https://drive.google.com/open?id=1MSZqypBSM5zzzqKB18EzNU-aRrQ6NUQh

               

              this says that the signing certificate isn't included.. the one that is assocaited with LHG7W4C55M in target "app name" but i don't know where the word target ever appears in xcode publishing options.  yet that's the only certificate I ever created.  I've tried my best to keep all things referencing LHG7W4C55M to make sure things stay consistent.. 

               

               

               

              archive checklist

              - i select "generic ios device" to do archive as i've read in tutorials.  not an emulator or even a locally connected device. 

              - i get an error, which is what i quoted originally so it's not an app code problem it's an error regarding provisioning / certification stuff

              - i have created an app undre app store connect, no not all of the screenshots and such are fleshed out, but there is the bundleID which is consistent with what i've put out there

              - my account was idle for awhile, but recently had made sure to purge / flush out all prior certificates / mobileprovisions to clean house as much as possible. 

               

               

              I can definitely test / build to a locally connected device so that's ok.  I'm trying to get the app to testflight which is why I'm trying to archive. 

               

              the cleaning folder suggest was nice. it got rid of a lot of initial warning in my error screen.  thanks for that tip for the future, but ultimately i still got the same error

               

              I did see that other thread but didn't seem to be specific enough to what i was experiencing, that thread was regarding a guy who upgraded from an older versoin of xcode.. which could itself be a whole other issue.  i've only used 10.1 from the start.  however thank you for the advice on that thread as well.