3 Replies
      Latest reply on Sep 11, 2019 8:26 AM by Thorh73
      salva73 Level 1 Level 1 (0 points)

        Hi,

        I'm migrating one app from iOS 12 to iOS 13 for testing, and I just noticed that in iOS 13 I'm not able anymore to import files with the extension ".app" inside the app (in my context .app files are just binary files). The app is not showing up when you try to "consume" one .app file from the Files app in the device, for example, whereas with iOS 12 it showed up.

         

         

        In iOS 12, in Xcode, under imported UTIs, I used to configure just the following:

        identifier: com.domain.app

        conforms to: public.data

        UTTypeTagespecitication:

        Item 0 -> app

        Item 1 -> APP

         

         

        With iOS 13 I've tried more or less everything (defining a document type, using apple.com.application, apple.com.package, apple.com.bundle, but nothing worked.

         

         

        Could you please suggest me the correct configuration for the Imported UTIs, while using iOS 13 and the new Xcode 11.0 (at the moment I'm using Beta 5).

         

         

        Thanks a lot,

        Salva