0 Replies
      Latest reply on Jun 27, 2019 3:23 PM by kara12321
      kara12321 Level 1 Level 1 (0 points)

        I am currently testing an INUIAddVoiceShortcutButton (add to Siri button) on an iPhone 6 running iOS 12. From the user's point of view, when the view controller with the add to Siri button is presented, it all seems fine and works perfectly. However, the Xcode debugger comes up multiple times with the following error:

        2019-06-27 12:07:04.380289+0800 AppName[917:129578] [default] No results found for query: {( <_LSApplicationIsInstalledQuery: 0x281061260> )}

        The slightly unexplainable part, is the fact that when I run the same app on a different iPhone 8+ (also running iOS 12), this error does not pop up.

         

        I have tried using breakpoints to find the root of this issue but to no avail. If anyone could tell me what this error means, or point me in the right direction that would be brilliant.

         

        NB: I only assume this is to do with the Siri Shortcuts button as this is what comes up when I search google with the error. If I am wrong please correct me.