2 Replies
      Latest reply on Aug 2, 2019 6:13 PM by YojimboMaster
      farago Level 1 Level 1 (0 points)

        Anyone else seeing this??

         

        No problem on unanimated glTF files - but polys break even on simple animations.

         

        Currently successful using

        • gltf2usd.py > USDA
        • Xcode usdz_converter > USDZ
        • Re: usdzconvert breaks polygons in glTF animations
          caroline Level 1 Level 1 (0 points)

          I have tried a simple waving arm (4 bones) glTF skeletal animation exported from Blender, and yes, usdzconvert doesn't convert properly for me. Polys look ok (in QuickLook), but the animated arm is in the wrong place. I have had a little success by exporting to fbx from Blender, converting to dae in Cheetah 3d, then importing the dae to a SceneKit .scn file and exporting usdz from there. It looks good in QuickLook and Xcode, but I haven't been able to load it successfully yet in Model I/O (but may just need more time!). I haven't tried more complex animations yet.

           

          I had previously used gltf2usd for this animation, and that one loads. The bone structure of this file looks very different to the usdzconvert one when compared in Xcode.

           

          However, I just checked the glTF sample walking CesiumMan.glTF from https://github.com/KhronosGroup/glTF-Sample-Models/tree/master/2.0/CesiumMan, and the resulting .udsz file using usdzconvert appears successfully animated in QuickLook.

           

          An animated cube dae converted via SceneKit with just transform animation loads fine in Model I/O.

          • Re: usdzconvert breaks polygons in glTF animations
            YojimboMaster Level 1 Level 1 (0 points)

            Do you have your 3D gltf animation asset to take a look? I might be able to help, I dealed with hundreds of GLTF conversions with all kind of weird issues.

            In Blender, you can try exporting as FBX, bring back in the FBX, then export as GLTF before using usdzconvert. Good luck!