6 Replies
      Latest reply on Apr 23, 2020 4:25 AM by WilliamZWang
      electricespeon Level 1 Level 1 (0 points)

        When trying to use sidecar with my iPad 6th gen I get "A miscellaneous error occurred (-401)" after my laptop and iPad screen flash black for a moment. Anybody else having this problem and/or have a solution?

        • Re: Sidecar error
          TomGG Level 1 Level 1 (0 points)

          same issue since yesterday, sidecar was working for few days, but has stopped with this error message. restarting both devices, no effect.

          • Re: Sidecar error
            slackerboy Level 1 Level 1 (0 points)

            I was having the same issue the other day. The USBC-USBC cable I was using momentarily loses connection on occasion, so I then tried it on Wi-Fi and was able to get it to work. If you are using Wi-Fi for your internet connection for your Mac, either turn off Wi-Fi on your iPad or make sure they are on the same network.

             

            Hope this helps.

             

            Fred

             

            (Note: This was on a 2015 MacBook Pro)

            • Re: Sidecar error
              Th3Randy Level 1 Level 1 (0 points)

              Electricespeon, I was also experiencing this issue.  I have found that it may have something to do with being plugged in at the start of sidcar.  When I unplug my iPad Pro 3rd Gen (Thunderbolt) from my MacBook and then start sidecar, its almost instant and I can use it as a second monitor.  Then I can plug it back in so that it can charge while I use it as a second monitor.

               

              If it's plugged into my mac at the time of starting sidecar...both screens will flicker black while the ipad remains black and even has the sidecar touch controls; ultimately it closes on the ipad and i get the Error 401 on MacOS.  Unplug the ipad, and works instantly again.

               

              Give this a go.  Let me know if this helps.  Thanks

                • Re: Sidecar error
                  electricespeon Level 1 Level 1 (0 points)

                  I have tried this and get the same error either way, but after updating to beta 2 on all my devices its giving me new errors "Unable to retrieve NWConnection for ClientID" when I try it with no cable and "GKVoiceChatServiceErrorDomain error 32002" when I do it with a cable. Quite strange

                • Re: Sidecar error
                  lauborgesc Level 1 Level 1 (0 points)

                  I get the same error and it started after update to beta 2.

                  The error happens using cable or wifi.

                  "Unable to retrieve NWConnection for clientID"

                  • Re: Sidecar error
                    WilliamZWang Level 1 Level 1 (0 points)

                    Apr 23, 2020, and still hasn't been fixed yet ~ SideCar is still in the ditch.