1 Reply
      Latest reply on Apr 15, 2019 12:39 PM by KMT
      photoyourimage Level 1 Level 1 (0 points)

        My iPHone was recently upgraded to iOS 12.2.  Immediately after, I was not able to connect my iphone to my MAC and run the simulator using xcode 10.1.  It indicated, "This iPhone XS is running iOS 12.2 (16E227), which may not be supported by this version of Xcode".  Is anyone else having this issue?  And how can I fix it so I can run my simulator?  I did update xcode to 10.2 but then I was not able to move code to Apple Store telling me it was a beta version.  HELP?

        • Re: Simulator on iPhone 12.2 not compatible with Xcode 10.2
          KMT Level 9 Level 9 (13,915 points)

          iOS 12.2 on your device expects Xcode 10.2 on your mac. Xcode 10.1 doesn't speak iOS 12.2, Xcode 10.2 does. Not sure I understand your simulator issue/question, as I would not expect a problem w/it when 12.2/10.2 is in play.

           

              >not able to move code to Apple Store telling me it was a beta version.

           

          Confirm you installed Xcode 10.2 release...not a 10.2 beta. Are you using a beta iOS on your device?