9 Replies
      Latest reply on Mar 19, 2019 2:18 PM by berndvombarch
      Finwes Level 1 Level 1 (0 points)

        Facing a weird issue from few days now:

         

        If I set the automatic signing in Xcode to true, it successfully generates a provisioning profile. The debug build then proceeds as usual and the app is installed to my device, however the debugger fails to attach to the process. The error message in Xcode reads '[my iPhone] has denied the launch request.'

        After some struggle I found out that the 'get-task-allow' flag is set to false in the automatically generated provision. As the account that I use is not enrolled in the development program, I am not able to change the generated parameters of the provision profile using the web interface. I guess that it is the cause of my problem.

        An attempt to change the value of the flag in the entitlements results in the conflict between my entitltments and the generated profile.

        The same problem occurs for the blank newly-created projects that should work out of the box. I tried rebooting and updating everything, wiping my phone and even using another Mac. Same error for all projects – both old and new.

         

        Does anyone know how what causes this issue, I really need to debug in device and I'm stuck here ?