6 Replies
      Latest reply on Oct 12, 2019 2:41 AM by Mmrec
      seta masahiro Level 1 Level 1 (0 points)

        about  iMessage app's development

         

        upload my xcode to 10.1 when i get the warning

         

        WARNING ITMS-90725: "SDK Version Issue. This app was built with the iOS 12.0 SDK. Starting March 2019

         

        and set up deployment target as follows

        build setting → General → Development Target「12.1」

         

        but i still get such as the following when i distribute my App

         

        App Store Connect Operation Warning WARNING ITMS-90725: "SDK Version Issue. This app was built with the iOS 12.0 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later."

         

        App Store Connect Operation Warning WARNING ITMS-90747: "Architecture incompatible with MinimumOSVersion. The app bundle at '[Aplication Name].app' specifies a MinimumOSVersion of '12.1' but contains a 32-bit architecture that is unsupported on iOS 12 and later."

         

        App Store Connect Operation Warning WARNING ITMS-90747: "Architecture incompatible with MinimumOSVersion. The app bundle at '[Aplication Name].app/PlugIns/[Aplication Name] StickerPackExtension.appex' specifies a MinimumOSVersion of '12.1' but contains a 32-bit architecture that is unsupported on iOS 12 and later."

         

        Do i need worry about the warning?

         

         

        ※I set up deployment target to 10.1 as follows

        「specifies a MinimumOSVersion of '12.1' 」

         

        then solved the following 2 problems

         

        ■App Store Connect Operation Warning WARNING ITMS-90747: "Architecture incompatible with MinimumOSVersion. The app bundle at '[Aplication Name].app' specifies a MinimumOSVersion of '12.1' but contains a 32-bit architecture that is unsupported on iOS 12 and later."

         

        ■App Store Connect Operation Warning WARNING ITMS-90747: "Architecture incompatible with MinimumOSVersion. The app bundle at '[Aplication Name].app/PlugIns/[Aplication Name] StickerPackExtension.appex' specifies a MinimumOSVersion of '12.1' but contains a 32-bit architecture that is unsupported on iOS 12 and later."

         

        but still seems the following problem

         

        ・App Store Connect Operation Warning WARNING ITMS-90725: "SDK Version Issue. This app was built with the iOS 12.0 SDK. Starting March 2019, all iOS apps submitted to the App Store must be built with the iOS 12.1 SDK or later, included in Xcode 10.1 or later."

         

        Could you teach me how to fix the problem thank you very much.