0 Replies
      Latest reply on Jan 10, 2019 12:37 AM by ElenaS
      ElenaS Level 1 Level 1 (10 points)

        System preferences -> Keyboard -> Text(tab)  -> "Automatic by Language" settings does not work with 3rd party spelling dictionaries.

        I've put my Lithuanian language spelling dictionary into ~/Library/Spelling (lt_LT.aff, lt_LT.dic)

        Yes, i've done "Set Up..." which is last option language selection.

        Yes, i've only check-marked only those(two) languages that i'm interested(English, Lithuanian).

        Yes, i've dragged them to the top in following order:

        1) Lithuanian

        2) English(U.S. English)

        Please see screenshot

        Yes, i switch keyboard layout in the document to a language layout i indend to use.

        I've chosen option Spelling and Grammar -> Check spelling -> While typing.

        And it fails. It underlines words in red.

        When i ask to present me with correct options, it presents with the list and in this list there are those exact words, presented in the same way 1:1, but somewhy when i type it things it's wrong.

        Please see screenshot

        Why is that and how to correct this ?

         

        By the way everything works perfect if i deselect "Automatic by Language" and choose one language, thus everything is ok with spelling dictionaries.