5 Replies
      Latest reply on Feb 6, 2019 8:51 PM by hotpaw2
      kyb Level 1 Level 1 (0 points)

        I maintain an audio editing application and I recently noticed that the debug builds I run during development (the most plain ones you get by pressing CMD B or CMD R in Xcode) don't get access to the microphone. You don't get any error message or dialog box asking for permission - the audio input is just a bunch of 0.0s.

         

        My fully signed (for distribution, either developer id or mac app store) builds have no problems with that. They can record fine.

         

        Now this is very annoying when I try to do actual development work. I cant sign & export a build every time I try to test something.

         

        So, what kind of user error am I making here? Do I need to set up some fancy development provisioning certificate to get this working? I tried removing the (release build) applications from the Security & Privacy "access to microphone" panel to maybe re-set the permissions dialog. But I don't see how. There's no remove option, only unchecking the checkbox. Which, as expected, just nulls the audio input.

         

        /edit: Running Mojave 10.14, Xcode 10.0 (all release, no beta) - recording device is built-in MacBook Pro microphone. (The device does work fine).