3 Replies
      Latest reply on Jul 3, 2019 7:23 AM by VB Reddy
      minggliangg Level 1 Level 1 (0 points)

        Hi,

         

        I have recently removed Safari Technological Preview using AppCleaner from https://freemacsoft.net/appcleaner/.

        The issue that I am facing is that there is a residual file named "SafariFamily" (with no extension) that I can't seem to get rid of no matter what i tried.

        • Dragging the item into the trash would result in the error message:

             "The operation can’t be completed because one or more required items can’t be found. (Error code -43)"

        • Placing the file in a folder, put the folder in trash and trying to empty trash would result in:

             "The operation can’t be completed because the item “Folder” is in use."

        • Using sudo rm on the file results in:

             "rm: SafariFamily: Operation not permitted"

         

        I have also tried deleting the item from safe mode as will as using the First Aid in Disk Utility.

         

        Any idea how I can remove it?

        • Re: Can't Remove SafariFamily
          Jay7962 Level 1 Level 1 (0 points)

          Not sure if you've found a fix for it yet, but I was having the same issue.


          What worked for me is booting into recovery mode and disabling system integrity protection (csrutil disable) and rebooting. Then I used terminal to force empty the trash containing Safarifamily (sudo rm -R <path to file in trash>)  You can just simply open the trash in finder and drag the file or parent folder into the terminal, just make sure there is a space after -R

           

          just remember to boot back into recovery mode afterwards and re-enable system integrity protection (csrutil enable)