9 Replies
      Latest reply on Oct 18, 2018 3:42 PM by vneto
      randomizer Level 1 Level 1 (0 points)

        Yesterday the XCode 10 simulator was running fine. Today, instantly crashes upon launch.

        I have run the XCode 9 simulator and reset simulator. I have "installed" XCode 10 from app store.

        Is there a preference I can delete for the simulator?

         

        Crashed Thread:        0  Dispatch queue: com.apple.main-thread

         

        Exception Type:        EXC_BAD_ACCESS (SIGSEGV)

        Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000000

        Exception Note:        EXC_CORPSE_NOTIFY

         

        Termination Signal:    Segmentation fault: 11

        Termination Reason:    Namespace SIGNAL, Code 0xb

        Terminating Process:   exc handler [0]

         

        VM Regions Near 0:

        -->

            __TEXT                 000000010a1cc000-000000010a271000 [  660K] r-x/rwx SM=COW  /Applications/Xcode.app/Contents/Developer/Applications/Simulator.app/Contents/MacOS/Simulator

        • Re: Simulator crashes immediately upon launch
          mijn-design Level 1 Level 1 (0 points)

          Similar problem here, never had any problem before Xcode 10

          System: MacPro 5,1, 12 core, 48 GB RAM, AMD Radeon R9 280X 3072 MB

           

          Crashed Thread:        26  Dispatch queue: com.apple.SimulatorKit.simDisplayRenderableView.B13E4118-0E84-4278-910F-4F8A526F82D3

           

           

          Exception Type:        EXC_CRASH (SIGABRT)

          Exception Codes:       0x0000000000000000, 0x0000000000000000

          Exception Note:        EXC_CORPSE_NOTIFY

           

           

          Application Specific Information:

          *** Terminating app due to uncaught exception 'NSInvalidArgumentException', reason: '-[FXPCRemoteProxy didChangeDisplaySize:options:]: unrecognized selector sent to instance 0x618000098240'

          abort() called

          terminating with uncaught exception of type NSException

            • Re: Simulator crashes immediately upon launch
              sfischr Level 1 Level 1 (0 points)

              I have had this same problem yesturday. I closed all apps, deleted file, shut down mac and restarted. Still didn't work, deleted Xcode, reinstalled for the fourth time, rebuild app, run, build successful, simulator run, click button, crash EXC_CRASH (SIGABRT).

              This was my first time using Xcode and Swift. Was not expecting this to happen since it seems it doesn't happen to the YouTubers and Udemy instuctors. (false sence of hope). Also trying to figure this out on my own.

            • Re: Simulator crashes immediately upon launch
              Xavier Level 1 Level 1 (0 points)

              I have the exact same crash report as you from the simulator Randomizer.  Ugh, if anyone finds a solution please post it.  I've tried reinstalling XCode and didn't work for me.

              • Re: Simulator crashes immediately upon launch
                SM-Wistful-CC Level 1 Level 1 (0 points)

                I was getting strange "Unable to Boot Simulator" and "Launchd failed to respond" errors yesterday. A lot of the suggestions online did nothing to fix it, but upgrading my OS finally got it working agian. It still behaves strangely and I have to launch Simulator.app myself, but the important thing is that it's working again.

                • Re: Simulator crashes immediately upon launch
                  KB7APP Level 1 Level 1 (0 points)

                  The exact same errors for me as well *SIGH*, absolutely NO simulator will work, I've tried both iPhone and iPad simulators, no dice anywhere.

                   

                  From what I've been reading this seems to be an UPGRADE issue.  I was on High Sierra running XCode 9.x and all was perfect.  Then I upgraded to 10.... KABOOM :-( ... everything went to crap.  I've tried upgrading to Mojave, just in case there was some sort of incompatibility in a framework component somewhere, that didn't work, and I've tried uninstalling XCode, ( yeah, I know, that leaves orphaned files hanging around, so I wasn't really holding my breath on that one ), rebooting, and reinstalling 10 from the AppStore.... again, no dice :-(

                   

                  Thing is, my friend did a CLEAN install of XCode 10 on Mojave, and his simulators all work flawlessly.  Gggggrrrrrr.... so that's why I'm thinking this has to do with the upgrade path.  The only thing keeping me from being completely ticked off is that I am able to test things out on my physical iPhone... at least they didn't break that.

                   

                  It seems as if Apple may have gone the way of a lot of other software companies and axed their Testers,  I mean, who needs Quality Control anyway, right?  That's what all us consumers are for... we test their released product so they don't have to pay employees to do it :-(.

                   

                  **Apple folks**.... can one of you PLEASE chime in here ... at least tell us you're reading these, as well as all the Error Reports that you have to be getting from the crash reports.  Is there an Update with a fix coming anytime soon?

                    • Re: Simulator crashes immediately upon launch
                      KB7APP Level 1 Level 1 (0 points)

                      Update....

                       

                      Ok, so I was able to REVERT back to XCode 9.4 and now all is well again.  I sure hope Apple gets their rears in gear and act together and fixes XCode 10 soon though, I would very much like to use it.

                       

                      In case folks need to revert as well... I just uninstalled XCode 10, rebooted, ( to release any 'in use' resources ), downloaded XCode 9.4 from the Apple Developer website, ( Here: https://developer.apple.com/download/more/ ), which will downloaded an XIP file, ( basically a Zip with built in checksum to verify ), double clicked the .xip file to extract the actual XCode app itself, and VOILA!!!  An XCode version with working Simulators once more :-)

                       

                      Note: The archiver will extract the file inside the Downloads folder, so you'll need to drag the app over to Applications manually after the fact... but that's easy enough to do.  Then you can delete the XIP file to reclaim the 5 GB of space again.

                        • Re: Simulator crashes immediately upon launch
                          fivenoom Level 1 Level 1 (0 points)

                          I have made an small investigation here but without any success, I think it is due a program compatibility with the OS (High Sierra or Mojave), so nothing to do here.

                           

                          As you mentioned KB7APP in a previous comment above, it is needed to install Mojave and install XCODE 10 so it seems (and I suppose) it fixes the issue.

                           

                          Otherwise we need to downgrade to 9.4 since it was already tested with High Sierra as you mentioned ( I will try this right away!).

                           

                          For more information you can check in dmesg messages that there is an issue with permissions to write in the sandbox and also with the program "Simulator" itself.

                           

                          You can try running as follow:

                          sudo /Applications/Xcode.app/Contents/Developer/Applications/Simulator.app/Contents/MacOS/Simulator

                          And you will get the below error:

                          Segmentation fault: 11

                           

                          If you try to open the simulator again you will see that the IPHONE/IPOD/IWATCH whatever device you are simulating is still running in the back but it goes away with the crash of the simulator, so I don't understand the point here.

                           

                          My dmesg messages were something like this everytime that the Simulator crashed:

                           

                          Sandbox: fseventsd(60) System Policy: deny(1) file-read-metadata /private/var/folders/7f/6dsw7z5s2w59fklv68r_97gm0000gn/0/com.apple.LaunchServices.d

                           

                          I will try with the version 9.4 and let's see if it fix my issue.

                      • Re: Simulator crashes immediately upon launch
                        andreasFromLauf Level 1 Level 1 (0 points)

                        Hello,

                         

                        since yesterday i have the same issue - is there already a solution exept going back to 9.4 ?

                         

                        OS: Mojave  (10.14)

                        Xcode 10.0 (10A255)

                        • Re: Simulator crashes immediately upon launch
                          vneto Level 1 Level 1 (0 points)

                          The following command fixed the issue one my mac

                           

                          sudo killall -10 com.apple.CoreSimulator.CoreSimulatorService

                           

                          Credit goes to https://stackoverflow.com/a/52500587/227148