2 Replies
      Latest reply on Feb 25, 2020 8:58 AM by Old Blue Nose
      AngryMan Level 1 Level 1 (0 points)

        Deleted Safari Technology Preview that was released today for space issues on my drive. There continues to be a problem that I am unable to solve. There's a file in the trash that cannot be deleted. It name "SAFARIFAMILY" it is in the trash but cannot be deleted.  Finder says that it cannot be deleted becusae it is in use.

         

        I have tried to rename it inthe trash and then delete it...finder says t hat it is in use and cannot be deleted. I have tried renaming it and then deleting it no luck. I tried to secure erase it to no avail. I have tried to shred it and then empty the trah, it's still there. I even reinstalled the OS and the Safari Technology app and deleted it but the mystery file remains. I even pulled it to the desktop to try and retrash it...the rsult, it douplicated itself. Now I have two fo them in trash!

        Any ideas on what to do to get rid of it? I would really appreciate any advise!

        Thanks & Sleep well!

        • Re: What is a SafariFamily file and why can't it be deleted from the trash?
          Jay7962 Level 1 Level 1 (0 points)

          Not sure if you've found a fix for it yet, but I was having the same issue.


          What worked for me is booting into recovery mode and disabling system integrity protection (csrutil disable) and rebooting. Then I used terminal to force empty the trash containing Safarifamily (sudo rm -R <path to file in trash>)

           

          just remember to boot back into recovery mode afterwards and re-enable system integrity protection (csrutil enable)

            • Re: What is a SafariFamily file and why can't it be deleted from the trash?
              Old Blue Nose Level 1 Level 1 (0 points)

              Excellent advice. Thank you.

              One observation. .The terminal message made it seem that 'disable' worked and reboot was a verification step, so I decided not to.  I was able to remain in recovery mode, and removed that folder and contents, use the enable command, then I just restarted my imac.

              Things appeared normal and that pesky Directory and contents were gone.

               

              and verified-------------------------------

              But what do I know? % csrutil status

              System Integrity Protection status: enabled.

              But what do I know? %