6 Replies
      Latest reply on Feb 2, 2020 10:40 AM by dinob68
      c98.d Level 1 Level 1 (0 points)

        I use Xcode 10 beta 3 to create a single demo app, when builds, it failed and shows: Encountered an error communicating with IBAgent-iOS.

         

         

        The full message belows:

         

        2018-07-04 16:40:32.249 ibtoold[2244:210597] [MT] DVTAssertions: Warning in /Library/Caches/com.apple.xbs/Sources/IDEInterfaceBuilder/IDEInterfaceBuilder-14295.6/InterfaceBuilderKit/Utilities/IBAbstractInterfaceBuilderPlatformToolManager.m:419

        Details:  Failed to attach to IBAgent-iOS with error: Error Domain=com.apple.InterfaceBuilder Code=-1 "Encountered an error communicating with IBAgent-iOS." UserInfo={NSLocalizedFailureReason=IBAgent-iOS (2246) failed to launch and exited with status 11, NSUnderlyingError=0x7febf5825320 {Error Domain=com.apple.InterfaceBuilder Code=-1 "Failed to launch IBAgent-iOS via CoreSimulator spawn" UserInfo={NSLocalizedDescription=Failed to launch IBAgent-iOS via CoreSimulator spawn, NSUnderlyingError=0x7febf5826ab0 {Error Domain=com.apple.InterfaceBuilder Code=-1 "Failed to handshake with platform tool" UserInfo={NSLocalizedFailureReason=Failed to open connection over FIFOs with platform tool, NSLocalizedDescription=Failed to handshake with platform tool, NSUnderlyingError=0x7febf5824a00 {Error Domain=com.apple.InterfaceBuilder Code=-1 "" UserInfo=0x7febf046bf90 (not displayed)}}}}}, NSLocalizedRecoverySuggestion=Please check Console.app for crash reports for "IBAgent-iOS" for further information., NSLocalizedDescription=Encountered an error communicating with IBAgent-iOS.}

         

         

        So, what's up? And how can I solve it? Anyone help me please..