7 Replies
      Latest reply on Jun 21, 2018 6:45 PM by DanaJets
      chrispylizard Level 1 Level 1 (0 points)

        Can’t see this as a known issue in the release notes. When in driving / walking directions, Maps does not keep pace with the device’s position, causing Maps to lag behind with turn by turn directions. Sometimes up to 30 seconds passes between the location updating. Anyone else experiencing this issue? iPhone X, 64GB, Dev beta 2.

        • Re: Maps not tracking movement
          cmaier Level 2 Level 2 (20 points)

          People have been reporting gps tracking problems since beta 1, mostly with qualcomm-equipped iPhone x’s 

           

          they have also been reporting that it is much better in beta 2, and that resetting network settings or earring tracked locations in privacy solved it for them in the first beta.

          • Re: Maps not tracking movement
            DanaJets Level 1 Level 1 (0 points)

            I had this issue with the beta 1 and resolved it by downloading the restore image and restoring the iphone through itunes.  Oddly enough, beta 2 did not have the issue for me, untill this morning.  I was going to try the method that worked for beta 1, however my phone "appears" to not be having the issue anymore.

            • Re: Maps not tracking movement
              AndyQ Level 1 Level 1 (0 points)

              I had problems with both Waze and Apple Maps last night unable to connect to GPS (worked fine in the morning).

               

              Ended up toggling off and on Location Enabled which eventually seemed to fix the problem.  And was working again this morning.

               

              Will see what happens later.

              • Re: Maps not tracking movement
                KevinS72 Level 1 Level 1 (0 points)

                We have another thread regarding the GPS issues.  After my beta 1 had been fixed, the issue returned after the beta 2 was applied via OTA.  I just applied the full restore image of beta 2 using the Upgrade method so hopefully that will resolve it until the next OTA update. ;-)

                https://forums.developer.apple.com/thread/103783

                 

                So far the best fix for now has been downloading the full restore ipsw file and using iTunes to apply the image using Shift-Click (Windows) on either the Check for Upgrade or Restore iPhone button and then using the downloaded ipsw.  The Check for Upgrade method is faster if it works for you since it doesn't need to restore your settings and data after the image is applied.  Hope that helps. :-)