2 Replies
      Latest reply on Jun 7, 2018 2:26 PM by paultklenk
      joihoino Level 1 Level 1 (0 points)

        When I click shutdown or restart from the apple menu I'm left with a black screen with a cursor but nothing in Mojave does anything.  When I run   halt or shutdown from from terminal, this is what I'm left with:

         

        sudo shutdown -r now
        Password:
        Shutdown NOW!
        shutdown: / is busy updating; waiting for lock
        
        
        

        But you know what, no problem, I'll just try to unmount the disk as is and see how it plays out:

         

        diskutil unmount force /dev/disk1s1
        Volume Macintosh HD on disk1s1 failed to unmount: dissented by PID 0 (kernel)

         

        Seems like a reasonable response....

         

        So yeah, I'm at a loss, anyone have any ideas?  I do have a multitude of orphaned nodes when I run First Aid in diskutil, but it doesn't try to clean them up or anything.  I'm not really sure what the behavoir is supposed to be for orphaned node on macos but it would have been nice to see diskutil do something about them.

         

        Using a Mid 2017 MBP with 16GB/2.9GHz/RP560/1TB

        • Re: Unable to reboot or shutdown through software
          joihoino Level 1 Level 1 (0 points)

          Fixed it.  I ran the shutdown command then started killing likely suspects in in activity manager.  Turns out kextd was the culprit. I thought. would have to go back after restart and kill it every time I wanted to restart until I found the offending kext but after that initial quit command everything is functioning as it should.

          • Re: Unable to reboot or shutdown through software
            paultklenk Level 1 Level 1 (0 points)

            I have a similar problem, but it's beyond the scope of this answer.  First, I have many, many orphans nodes, and as noted, there is no way to get rid of them.  Next problem is probably my creation by installing Mojave over beta High Sierra.  BootCamp, Windows 10, operates as it should and there are no issues with BootCamp.  However, I cannot shut down Mojave.  It goes into a reboot and shows me, what I think, is a kernel panic, but proceeds with a couple of warnings to restart.  Indicates that I did not shut down properly. 

             

            Tried the first, three, terminal command as above and it does, indeed, "shutdown," but directly into a reboot.  I can live with it for now, but I would like to rectify it without a clean install.

             

            Any thoughts would be appreciated!