5 Replies
      Latest reply on Jun 20, 2018 7:28 AM by powderedtoast
      Leenert Level 1 Level 1 (0 points)

        Hi,

        since I've upgraded to XCode 10 / iOS 12, I get the following error during my ARKit configuration:

        [framework] -[CUINamedRecognitionGroup initWithName:contentsFromCatalog:usingRenditionKey:fromTheme:] couldn't find object named 'ResynchMarker' skipping

        I've tried to readd all the pictures, tried different pictures, but it's still not working. It seems, that this is the reason, why my images are not detected anymore. Does anybody have the same issue?

         

        Cheers

        • Re: ARKit Image Detection "Couldn't find object named..."
          Bersaelor Level 1 Level 1 (0 points)

          Installed Xcode 10 today, facing the exact same problem.

          The whole

          ARReferenceImage.referenceImages(inGroupNamed: "characters", bundle: Bundle.main)

           

          didn't work, while loading the pictures individually did, like so:

           

              let warrior = ARReferenceImage(UIImage(named: "warrior")!.cgImage!,
                                             orientation: CGImagePropertyOrientation.up,
                                             physicalWidth: 0.038)
              let barbarian = ARReferenceImage(UIImage(named: "barbarian")!.cgImage!,
                                             orientation: CGImagePropertyOrientation.up,
                                             physicalWidth: 0.038)
              let rogue = ARReferenceImage(UIImage(named: "rogue")!.cgImage!,
                                             orientation: CGImagePropertyOrientation.up,
                                             physicalWidth: 0.038)
              let mage = ARReferenceImage(UIImage(named: "mage")!.cgImage!,
                                             orientation: CGImagePropertyOrientation.up,
                                             physicalWidth: 0.038)
          

           

                  configuration.trackingImages = [warrior, rogue, mage, barbarian]
          

           

          Guess it'll be fixed in one of the next betas..

          • Re: ARKit Image Detection "Couldn't find object named..."
            hardik.gajjar_softweb Level 1 Level 1 (0 points)

            I am also facing same issue , I am not able to detect image and its throw a error like below

             

            [framework] -[CUINamedRecognitionGroup initWithName:contentsFromCatalog:usingRenditionKey:fromTheme:] couldn't find image named 'a' skipping

            • Re: ARKit Image Detection "Couldn't find object named..."
              Neonstone Level 1 Level 1 (0 points)

              I get exactly the same issue with trying to detect scanned objects in the scene. It's a bit of a problem at the moment, as it makes the object detection functionality completely unusable. I wish there was some sort of workaround.

              • Re: ARKit Image Detection "Couldn't find object named..."
                jgkoenig Level 1 Level 1 (0 points)

                Same issue here developing natively on XCode 10. Any ideas yet? The suggestion to add them individually didn't work for me.