1 Reply
      Latest reply on Dec 15, 2015 3:10 PM by zisko
      Duncan C Level 1 Level 1 (0 points)

        I'm trying to run the leaks instrument on an iOS device but it doesn't show it as a valid target.


        I just upgraded to Xcode 7.2. I'm running OS X 10.10.5, in case that matters. I've verified that the version of Instruments that I'm running is the 7.2 version embedded into the Xcode bundle. (I had this same problem yesterday when running Xcode 7.1 and Instruments 7.1. I was hoping that upgrading to Xcode 7.2 would resolve it, but no such luck.)


        My project has a base SDK of 9.2 and a deployment target of 7.0.


        I have several different iOS devices I test with. The main device is a company iPhone 5s running iOS 8.4.1.


        I also test on my personal iPhone 6, which is running iOS 9.1.


        If I have the iPhone 5 connected to my Mac and choose "profile", I can select the leaks template and it shows the iPhone 5 as the target device and the app I am working on as the target app.


        If I connect the (iOS 9.1) iPhone 6 instead, and also select "profile" from Xcode and select the leaks instrument in the list of Instruments templates, I end up with my development Mac being the only target device that is active. I see the other devices listed when I click on the target control, but only the Mac and the "simulators" options are active. I just tried connecting both the iPhone  and the iPhone 6 at the same time, and in that case the iPhone 5 is enabled by the 6 is not.


        I can run the debug or release version of the app on the device from Xcode and it installs it, lanuches it, and lets me debug it, so I'm confident that the device trusts this Mac and that the provisioning profile is set up correctly. (I've changed my release build settings to use the development provisioning profile in order to keep things simple.)


        What am I missing? Is there some extra step I need to take in order to authorize an iOS device for running in Instruments that I have missed? I'm stumped.