29 Replies
      Latest reply on Oct 14, 2015 11:03 AM by dtbsz
      MikesTooLz Level 1 Level 1 (0 points)

        After installing iOS9 I am unable to join my WPA2 Enterprise wifi network. At first it was just saying invalid password, now its saying it cannot even find the network(hidden SSID entered manualy).

        • Re: ios9 wifi not fully working
          MikesTooLz Level 1 Level 1 (0 points)

          To be a little bit more specific.

          iPhone 6 Plus

          iOS9 - setup as new device.

          Reset of Network Settings had no effect.


          Connecting to Visible WPA2 network works. I'm not sure if its just the Visibility of the SSID, or WPA2 Enterprise, or both.

            • Re: ios9 wifi not fully working
              AndreTheGeek Level 1 Level 1 (0 points)

              I'm having the same issue with my Enterprise network. It tells me the password is wrong, or that it can't scan networks. Tried resetting network settings, rebooting etc. No luck.


              Non-enterprise networks working fine.

              • Re: ios9 wifi not fully working
                Level 1 Level 1 (0 points)

                I have the same issue.


                My device is an iPhone 6 16 GB space grey factory unlocked with iOS 9 public beta 2 (developer beta 4).


                I can use my Wi-Fi connection at home just fine (personal WPA-2), but my phone will not connect to an enterprise network with WPA-2 encryption. The error I receive is that my username and/or password is incorrect. I know that's a lie; my password as entered works with other sites with the same account (it's a college network).


                Resetting network settings does nothing to help my situation. I hope Apple fixes this in the next beta.

              • Re: ios9 wifi not fully working
                sstadelman Level 1 Level 1 (0 points)

                Seeing this issue also on Enterprise wifi network.

                • iPhone6
                • fresh install of iOS9 beta.


                Was able to connect to network with iOS 8.3.


                I am able to see the network, enter username/password, and accept server certificate.  But, I get the following notification:

                "No Network Connection.  The Wi-Fi network you selected is not providing an Internet connection.  Change your settings or choose a different network."

                • Re: ios9 wifi not fully working
                  Level 1 Level 1 (0 points)

                  Same here.  Won't accept password.  We are using Aruba.

                    • Re: ios9 wifi not fully working
                      trob55 Level 1 Level 1 (0 points)

                      I have been doing some work in a location that uses Aruba and I am running beta 5 and I see it connect to the guest network without encryption and then drop and reconnect at random.  Seemed to be fine since I went to the most recent beta. I have no issue with wifi anywhere else but here. Other devices can connect and use it without issue.

                    • Re: ios9 wifi not fully working
                      Level 1 Level 1 (0 points)

                      This is clearly stated as a known issue in the Beta 2 Release Notes...

                      • Re: ios9 wifi not fully working
                        rkmather Level 1 Level 1 (0 points)

                        I have an issue where the SSID is not broadcast at work and additionally requires a proxy server...  But I never even get to the proxy server, or the point where I enter it.  At first I thought it was due to the "_" in the SSID name, but I have one on my network at home...  the only two differeces are the "hidden network" and the proxy server.  It did connect once, out of the blue. but that was short lived and has never done it agan.

                        • Re: ios9 wifi not fully working
                          goldengamer Level 1 Level 1 (0 points)

                          I just installed public beta 3 and I have the same issue. I upgraded without doing a clean install, but it wouldn't connect to my work's WPA2 or unlocked network. I tried resetting the network settings, but that didn't fix the problem. On 8.4, wifi worked flawlessly so I don't think it's a hardware issue. Hopefully this can be fixed.

                          • Re: ios9 wifi not fully working
                            zollsoft Level 1 Level 1 (0 points)

                            Any updates on this with the GMs of iOS9 / El Capitan. The university network "eduroam" isn't working neither in Zurich nor in Jena (Ger).

                            • Re: ios9 wifi not fully working
                              marcushjorth Level 1 Level 1 (0 points)

                              I updated my iPad Air and my iPhone 5s just last night, and connecting to my home WiFi is not a problem. At work though, where we use WPA2, I cannot connect. It says, as for many others, that the password is incorrect (but it is NOT).


                              Is this a bug? Will it be fixed? I truly hope so, or else I'm a bit screwed.

                                • Re: ios9 wifi not fully working
                                  Magishan Level 1 Level 1 (0 points)

                                  I don't believe this is an isolated incident.

                                  I don't wish to repeat everything that everyone else has typed, so I'll briefly list the symptomology:


                                  Updated iPhone 5 to ios 9. installation appears to have been successful, no errors reported.


                                  When attaching to wifi (a pretty new Linksys wireless N router) WITH THE SSID HIDDEN, the device will not attach. WPA2 personal encyption being used, username and password verified, MAC ID filtering is utilized. ALL of these settings have been checked and are correct, and this is the same setup it's been for the last calendar year. Zero issues prior to the installation of ios 9.


                                  Herein are the observed symptoms: When the SSID beacon is active/broadcasting, phone will attach normally. If the phone settings are reset/cleared, info can be placed back into the phone, and the phone will attach normally.


                                  WHEN SSID IS ONCE AGAIN HIDDEN, the phone disconnects from the network, and nothing fixes it. Resetting and manually adding, auto connecting, nothing allows the phone to attach when the SSID beacon isn't broadcasting. If the beacon is turned back on, it's all golden again. This occurs on both my 2.4 and 5 Ghz networks.


                                  This is a problem for those of us who wish to mask/hide the presence of our network, to mitigate brute force hacks to gain access to it. I shouldn't have to turn the beacon on to reattach/make functional a device that's been running on this very same network under ios8 for over a year. I am very confident when I say this is a problem with ios9, and not with any of my hardware. My router, just for clarity, has the latest available firmware installed.


                                  How about a little help here Apple? Your silence on this issue is more than a little disturbing. Can I get a rebate on what I pay for your product?


                                  EDIT: After some more observation, the problem hasn't changed. That said, I also have an iPad mini with ios 9 installed, same network segment, same settings, and it retains connection after SSID is hidden. Iphone 5 still affected as stated above. This points to a flawed installation in the phone perhaps? But, no errors reported during the update, and no other performance issues are observed???

                                • Re: ios9 wifi not fully working
                                  Ib93 Level 1 Level 1 (0 points)

                                  I am having the same issue except the phones (I am testing with 3 different 5s models) also won't connect to wifi with WPA2 Personal. The SSID is not being broadcast. If I broadcast the SSID the phones have no issue connecting with the WPA2 Personal on.

                                  I have also tested with 3 different iPads (wi-fi only models)  and they have no issue connecting after iOS 9 Update With the SSID not broadcast and WPA2 personal on.


                                  Could there be a possible issue with the ipv 6 scrambling the MAC address for cellular capable devices?

                                  It seems that on all iOS 8 releases the 5s phones defaulted to ipv 4 networking.


                                  Could be wrong but something changed for the devices with cellular capabilities with the iOS 9 update that doesn't connect to WPA2 security when SSID is not broadcast.


                                  I am sure Apple will investigate this and produce a fix If they already aren't on it.

                                  • Re: ios9 wifi not fully working
                                    xXNEMESIXx Level 1 Level 1 (0 points)

                                    I partially solved the problem connecring to the network that is not broadcasting the ssid while already connected to another network that is broadcasting the ssid.


                                    I tried everything before that but nothing worked (dns, reset of network config, disable location service and so on).


                                    I hope this can help you hoping for a fix soon.


                                    ipad air 2 cell with ios9 (sadly)

                                    • Re: ios9 wifi not fully working
                                      Tom77w Level 1 Level 1 (0 points)

                                      Here is how I resolved my problem wih connnecting to corporate wiFi net and getting incorrect password error message. My iPad Air 2 was failing to connect to our Meru wiFi net after updating to iOS 9. So on my iPhone 6 Plus I turned on Personal Hotspot with an associated password. Next I successfully connected my iPad Air 2 to the new Personal Hotspot SSID with its password.  Then on the iPad Air 2 I attempted to connect to one of the SSID's on our coporate wiFi and viola I was able to successfully connect using the password as required.


                                      I do not know why this works yet but I have helped a large number of my collegues here at work with this solution. Come on Apple I know this is a known issue throughout the IOS 9 universe. I am beginning to have to explain to management why the Microsoft Surface tablet is not a viable solution for our mobile users. So getting this issue resolved ASAP is critical.



                                      • Re: ios9 wifi not fully working
                                        Yaybe Level 1 Level 1 (0 points)



                                        i'm working in a location where we can access our private phones 9.1 beta2 via a hotspot which is provide by an external partner and we musst accept the T&C and than the landingpage if forwared to the puplic internet.

                                        Now the forwarding from the landingpage to the puplic internet is not working since beta 9.1, but it was working with 9.1.. Since yesterday evening I have 9.1. beta 2 same issue.


                                        If i try this hotspot via my business phone it is working. Iphone & 9.0.1

                                        any one with this issue...?

                                        • Re: ios9 wifi not fully working
                                          cwe0002 Level 1 Level 1 (0 points)

                                          It appears that iOS 9.0.1 was released, stating that it fixes an issue with custom APN's. Any feedback on this update as it relates to this issue? We have users on our Meru WiFi systems that don't connect automatically anymore.

                                          • Re: ios9 wifi not fully working
                                            flyingbrick Level 1 Level 1 (0 points)

                                            We are having this issue with all of our iOS 9.01 devices 5c,5s, and 6. In 9.1 beta  2 it won't connect and asks for a password but if left alone for a few minutes it connects to the any of the saved SSIDs both hidden and broadcasting.

                                            • Re: ios9 wifi not fully working
                                              smcleod Level 1 Level 1 (0 points)

                                              iPhone 6+ Dev Beta 2, and iPhone 6s+ Public Beta 2 both cannot connect to WPA2 Enterprise Wireless.



                                              • TTLS with PAP inner auth
                                              • trusted cert included in bundle
                                              • iOS 9.0.1 and iOS 9.1 Beta 1 both worked on both devices.


                                              Server side error:

                                              • Radius server returns 'SSL Verify Failed'
                                              • Re: ios9 wifi not fully working
                                                KTF2015 Level 1 Level 1 (0 points)

                                                I hope apple get the bottom of it fix hidden said wifi issue.  9.0, 9.1 and 9.2 still not fix the wifi issue.



                                                • Re: ios9 wifi not fully working
                                                  dipteshr Level 1 Level 1 (0 points)

                                                  Put the phone into Airplane mode then go to wifi and swtich on WIFI ONLY. Connect to the network. Switch off Airplane mode.


                                                  The phone should remain connected to the wifi network    

                                                  • Re: ios9 wifi not fully working
                                                    smcleod Level 1 Level 1 (0 points)

                                                    Apple: If there is any information we / you can give to help resolve this issue - could you please let us know?

                                                    • Re: ios9 wifi not fully working
                                                      BobinVA Level 1 Level 1 (0 points)

                                                      I'm also having iOS 9.0.2 Wi-Fi WPA2 Personal connection issues with my LAN access point, using an iPhone 5s.  I have ~40 other devices connected to my Linksys router's AP using an unadvertised (hidden) SSID and MAC filtering without any problems.  When I advertise (unhide) my SSID, and continue MAC filtering, the iOS 9.0.2 iPhone 5s automatically recognizes my known SSID. When I un-advertise (hide) my SSID, and stop MAC filtering, the iOS 9.0.2 iPhone 5s automatically recognizes my known SSID. Only when I un-advertise (hide) my SSID AND MAC filter, does the 9.0.2 iPhone 5s fail to automatically recognize my known SSID, (manual connects also fail). It appears that Apple has decided to scramble the MAC address even when the iPhone is awake now. [Appearantly in iOS 8, the MAC address was only scrambled when the phone was asleep. I guess that since the iPhone only fully goes to sleep when it is OFF, AND out of WiFi AND cellular range kind of defeated the privacy concern about department stores tracking your radio pinging your MAC address and getting tracked.]  I applaud what Apple is trying to do , but I would hope that in future upgrades that they would enable MAC address scrambling only when outside your list of known networks, or add a switch to disable scrambling.  I think it is counterproductive to solve one privacy issue at the expense of opening back up a security issue.


                                                      P.S. I'm not interested in a discussion about the utility of hidden SSIDs and MAC filtering. Security is a onion, it has many layers because each has holes. The overall protocol is strong because of the compounded layers.