5 Replies
      Latest reply on Jan 15, 2020 1:43 AM by eskimo
      brantatsilabs Level 1 Level 1 (0 points)

        Hi. I need some help with a Notarization error.


        In this situation, I have a Jenkins job (Jenkins is a continuous integration system that builds software) that produces a signed dmg disk image containing an app  and a kernel extension.


        The Jenkins job that produces this was working correctly until today. No changes were made to the build machine or to the source code that it builds.


        The error that I am seeing is Error 65, "record not found" which happens when the Staple operation is attempted. I also receive an email with a subject line: "Your Mac software was not notarized."


        The software is being built using Xcode 10.3. The reason why I am not using Xcode 11 is because I am building a KEXT.


        I checked the signature using codesign -vvv --deep --strict on my disk image. It says "valid on disk" and "satisfies its Designated Requirement". I also verified that the system clock is correct within about a second on the build machine.


        I also tried building it on a second machine using the same script and received the same error.


        When the script uploads the disk image, I see a message saying "No errors uploading".


        Both machines I built on are running MacOS 10.14.6.