0 Replies
      Latest reply on Jan 12, 2020 2:52 AM by testUser3434
      testUser3434 Level 1 Level 1 (0 points)

        Hi everyone,


        I bought myself a new notebook. Then I transfered all the data from my previous macbook to the new one by using the

        migration assistant. After that, I created a new certificate (Apple Push Services) in the Apple developer portal. Using the keychain, I created a certificate signing request on the new mac so this means, I revoked the previous certificate in the developer portal and tried to the enrollment from scratch.


        Now my actual problem: I downloaded the .cer file. Whenever I do a doubleclick on it, the certificate is not imported into the 'My certificates' section in my keychain tool. But I need to export the p12 file, so how can I do that? The 'My certificates' section is completely empty and I am struggling a lot with this issue.

        When running Xcode, I get this:

        CodeSign /Users/nazarmedeiros/Library/Developer/Xcode/DerivedData/Delgado-duyvfumilkktardkhfafnctzmbys/Build/Products/Debug-iphoneos/OneSignalNotificationServiceExtension.appex (in target 'OneSignalNotificationServiceExtension' from project 'Delgado')

            cd /Users/nazarmedeiros/Desktop/My\ IOS\ Apps/Delgado\ Project/Delgado

            export CODESIGN_ALLOCATE=/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/codesign_allocate


        Signing Identity:     "Apple Development: Kaan Cayoglu (KG2HH59QBZ)"

        Provisioning Profile: "iOS Team Provisioning Profile: *"



            /usr/bin/codesign --force --sign B3B2F1EEA1C3E630DEFF25637172AA73A2944277 --entitlements /Users/nazarmedeiros/Library/Developer/Xcode/DerivedData/Delgado-duyvfumilkktardkhfafnctzmbys/Build/Intermediates.noindex/Delgado.build/Debug-iphoneos/OneSignalNotificationServiceExtension.build/OneSignalNotificationServiceExtension.appex.xcent --timestamp=none /Users/nazarmedeiros/Library/Developer/Xcode/DerivedData/Delgado-duyvfumilkktardkhfafnctzmbys/Build/Products/Debug-iphoneos/OneSignalNotificationServiceExtension.appex



        I also tried to do couple of other things:

        - Delete all the files under Library/Keychains

        - Reset all the keychains

        - Install Catalina again without deleting existing files

        - Create a new admin user and try it with it


        OS version: Catalina, 10.15.2


        Not sure if issue might be caused because having the keychain in iCloud (just a suggestion)


        Can anyone help me, please?