1 Reply
      Latest reply on Aug 21, 2015 7:22 AM by sean@vzw
      glawrie Level 1 Level 1 (0 points)

        It seems that if you have an old (not sure how old, but not current) version of VirtualBox on your OS X 10.11 beta <6, you'll not be able to complete the installation of OS X 10.11 beta 6 due to a kext induced crash during the late stages of the install migration.

         

        There are other threads that have appeared with discussions of these issues - e.g. here: https://forums.developer.apple.com/thread/13245.

         

        Finding a fix for this issue is not easy - and several have resorted to fully restoring a working OS X 10.11 beta 5 or earlier system, uninstalling the VirtualBox app using an uninstaller, and then trying to migrate to Beta 6 again.

         

        I found an easier way to fix this issue on my system.  This is what I did:

         

        • I restarted my system in safe mode - hold down the shift key during the boot sequence.  N.B. on my system this resulted in a very long pause in the resart sequence, and then once the restart had begun the completion of the Beta 6 install restarted, and this also took a long time (and required me to re-log-in twice).  But it did get me to a working desktop eventually.
        • In safe mode I then opened safari and downloaded the VirtualBox uninstaller from here - http://www.virtualbox.org/svn/vbox/trunk/src/VBox/Installer/darwin/DiskImage/VirtualBox_Uninstall.tool
        • I moved the uninstaller script to my home folder (~)
        • I ran the uninstaller in terminal using this command - sudo /bin/sh VirtualBox_Uninstall.tool Intially this command did not work, but adding the /bin/sh to the command line instruction made it work OK eventually.  This is the terminal log of what happened:
          sudo /bin/sh VirtualBox_Uninstall.tool
          
          Welcome to the VirtualBox uninstaller script.
          
          The following files and directories (bundles) will be removed:
              /usr/bin/VirtualBox
              /usr/bin/VBoxManage
              /usr/bin/VBoxVRDP
              /usr/bin/VBoxHeadless
              /usr/bin/vboxwebsrv
              /usr/bin/VBoxBalloonCtrl
              /Library/StartupItems/VirtualBox/
              /Library/Extensions/VBoxDrv.kext/
              /Library/Extensions/VBoxUSB.kext/
              /Library/Extensions/VBoxNetFlt.kext/
              /Library/Extensions/VBoxNetAdp.kext/
          
          Do you wish to uninstall VirtualBox (Yes/No)?
          Yes
          
          The uninstallation processes requires administrative privileges
          because some of the installed files cannot be removed by a normal
          user. You may be prompted for your password now...
          
          Successfully unloaded VirtualBox kernel extensions.
          Done.
          

         

        • I then restarted the machine and let it run normally - the restart took a very long time (it paused at the end of the grey-line phase for ages) - but eventually I got back to OS X 10.11 beta 6.

        This method worked for me, but maybe not anyone else.  If it does work for others, this might be a good thing compared to restoring an old version of OS X from Time Machine.

         

        HTH