1 Reply
      Latest reply on Feb 7, 2019 3:23 PM by KMT
      wookiee Level 1 Level 1 (0 points)

        I've got several coding fonts that I love. I've noticed that the latest versions of Xcode fail to render many of them, silently failing back to SF Mono when these fonts are selected in the Preferences.


        Here's a video demonstrating this problem when selecting the 'Fantasque' font:




        Has anyone else run into this, and have a workaround?


        Things I've tried:

        - verify that the affected fonts work elsewhere (Sublime Text, VSCode, Terminal)

        - uninstall and reinstall the affected fonts

        - clear macOS font cache and reboot


        Any ideas would be appreciated.

        • Re: Xcode not rendering certain fonts in editor
          KMT Level 9 Level 9 (15,785 points)

          You don't mention FontBook, but that would be my first step in this example.


          Confirm supported/healthy fonts, houseclean duplicates, outdated, etc.


          Still no joy, help Xcode 10.1 take a clean breath by deleting all plists w/xcode in the name located in~/Library/Preferences. Xcode will make new ones next start.


          Also confirm you've not renamed Xcode and it is intalled to /Applications on the boot drive and that your drive has several tens GB free space, trash emptied.