7 Replies
      Latest reply on Feb 17, 2019 12:50 PM by Claude31
      mleonhard Level 1 Level 1 (0 points)

        MacOS 10.14.2 (18C54)

        Xcode Version 10.1 (10B61)


        I'm following the "Start Developing iOS Apps (Swift)" tutorial:


        I got to the point "Checkpoint: Run your app. What happens when you click on the image view?" where it expects a SIGABRT crash due to a missing string that's needed to request permission to access photos.


        My app doesn't crash.  It shows the photo picker and it displays whatever photo I select.  It doesn't have a "Privacy - Photo Library Usage Description" string in Info.plist.  It doesn't ask for permission to access photos.  When I go to Settings / Privacy / Photos, the FoodTracker app doesn't appear.


        This happens in the simulator with iOS 12.1 and on my iPhone 6s (registered to my developer account) with iOS 12.1.2.


        Here are the debugger log lines from running in the simulator:

        2019-02-04 19:57:43.229284-0800 FoodTracker[1254:26226] libMobileGestalt MobileGestalt.c:890: MGIsDeviceOneOfType is not supported on this platform.

        2019-02-04 19:57:45.595264-0800 FoodTracker[1254:26226] [MC] System group container for systemgroup.com.apple.configurationprofiles path is /Users/user/Library/Developer/CoreSimulator/Devices/6802BA11-D1B8-48B6-BCD9-6B258FA9F88A/data/Containers/Shared/SystemGroup/systemgroup.com.apple.configurationprofiles

        2019-02-04 19:57:45.595585-0800 FoodTracker[1254:26226] [MC] Reading from private effective user settings.


        I clicked "Product / Clean Build Folder" and tried it again.  Same result.


        Does anybody know why this app seems able to bypass the iOS permissions on photos?  Did I accidentally discover a security bug?