37 Replies
      Latest reply on Jul 1, 2019 9:30 AM by mattn
      rodskagg Level 1 Level 1 (0 points)

        Since upgrading to XCode 10 my iOS simulators have become really slow. There's a lot of lag when scrolling in tableviews or scrollviews. Is anyone else having this problem?

        • Re: XCode 10 simulator slow
          Plaza Level 1 Level 1 (0 points)

          I got the same problem but it work fine on another mac. Don't know why !!!

           

          I can't work ! please Apple make some fix.

          • Re: XCode 10 simulator slow
            sundialsoft Level 1 Level 1 (0 points)

            My simulators have also slowed down by a large degree.

            I noticed that the XR sumulator is faster than the 8 plus one. Still slow but at least usable.

            • Re: XCode 10 simulator slow
              WarpRulez Level 1 Level 1 (0 points)

              I remember the time, many, many years ago, when the iOS simulators were actually extremely light, fast and efficient. They could simulate in real-time, full 60fps, even on slower Macs.

               

              With every new version of Xcode, the simulators have become increasing slower. By this point they have become so slow that they are almost unusable. The Xcode 9 simulators were already really slow (running at about 10 fps on this iMac), but now with Xcode 10 they have become even slower. In fact, it's worse now because with Xcode 9 they were slow, but at least the framerate was quite steady and consistent. With Xcode 10 there framerate will fluctuate, between about 10 fps and something like 2 fps, at random intervals, making it almost unusuable.

               

              This is even worse than ever before because now the simulator hogs 100% of CPU time, making everything in the operating system lag while the simulator is running. I can't do anything else at the same time.

               

              Luckily this is probably the last iOS project I ever have to do with Xcode.

              • Re: XCode 10 simulator slow
                FerliniIosdeveloper Level 1 Level 1 (0 points)

                II noticed a strong deterioration in the speed of execution of the simulator, now I'm working on the physical device because otherwise I can not work.

                • Re: XCode 10 simulator slow
                  Jaffa Level 1 Level 1 (0 points)

                  If numbers matter, I'd like to add my complaint to this issue.

                  Especially slow are Tableview scrolling in pop-overs,

                  slide across screens and pop-up views - with a lot of transparency.

                   

                  Using UIKit, Foundation, Core Graphics, MessageUI, and

                  WebKit.frameworks since iOS12 deprecated UIWebView.

                   

                  The App has dozens of Cocoa Gesture Recognisers and many Pop-Overs.

                  All worked fine when build for 10.3 targets - simulators often faster + smoother than physical device animation.

                   

                  Also previous Xcode environments allowed us to configure simulators for various fallback iOS versions - I think.

                  whereas now there is no fallback from 12.0 - is this true?

                   

                  Also note build has gone from 20 modules to 200 tasks, huh? (Objc & Swift4.2 mix)

                   

                  Thanks in advance

                    • Re: XCode 10 simulator slow
                      WarpRulez Level 1 Level 1 (0 points)

                      You can install older simulators from the menu Xcode > Preferences... > Components. (You might need to restart Xcode for it to notice the new simulator.)

                        • Re: XCode 10 simulator slow
                          Jaffa Level 1 Level 1 (0 points)

                          Thanks for the tip Warp. Rolled back to 11.4 for maybe 50% improvement. Still a bit hesitant and jerky. May need to roll back further until12.1 or 2 comes along. At 2GB per simulator its annoying, as they were all downloaded before and existing on my machine before 12.0 update.

                           

                          Other co-existing suspects.

                          * had a PUP (Mac Mechanic) on system - now gone I think?

                          * there has been a Java update recently?

                          * my mouse is intermittantly disconnecting. Reonnects on demand, but a new and bothersome symptom for a system which should have matured with robustness & reliability & some certainty after this many years. Apple's appetite for unwarranted change & deprecation irks me.

                      • Re: XCode 10 simulator slow
                        janhlange Level 1 Level 1 (0 points)

                        Simulators have become ridiculously slow. Timing any kind of transition or animation is impossible.  I have tried every solution so far from changing FramebufferRendererHint to reinstalling simulators.  I am about ready to go back to Microsoft world.  Yesterday (xcode 9.xx)  I was productive, today (Xcode 10) I cannot even get any work done.  Absolutely insane.  This is not a beta version either,  This is the production version.

                        • Re: XCode 10 simulator slow
                          lubber Level 1 Level 1 (0 points)

                          Slow to the point of being unusable. Yesterday, I was getting things accomplished. Today, I'm listening to my fans going into meltdown mode while the cursor slowly jumps across the screen.

                           

                          I saw people had complaints about this in Beta but apparently they decided to release without fixing it, noting that there might be problems, or even acknowledging the issue.

                          • Re: XCode 10 simulator slow
                            alexandrafromatlanta Level 1 Level 1 (0 points)

                            Experiencing the same issue here, especially from running Xcode 10.0 on macOS Mojave 10.14 Beta.

                             

                            Currently installing the GM version of macOS Mojave 10.14 so let's see if that resolves some of my issues.

                             

                            Also contemplating installing Xcode 10.1 Beta since the Release Notes have some fixes for bugs from the previous version, nothing detailing the level of slowness for the Simulators though.

                             

                            I've encountered a lot more issues using iOS 12.0 Simulators. Anything iOS 11 and below seems to work okay, just not as fast as anything on Xcode 9.4.1.

                            • Re: XCode 10 simulator slow
                              revi Level 1 Level 1 (0 points)

                              I got the same problem

                              • Re: XCode 10 simulator slow
                                alexandrafromatlanta Level 1 Level 1 (0 points)

                                Fixed my issue by installing Xcode 9.2 on macOS Mojave Version 10.14

                                 

                                Don't think Xcode 10 is ready to be all that usable right now (at least for me and for those who have been having a lag with their Xcode Simulators).

                                 

                                One thing that did help for sure was deleting Xcode 10 altogether, installing Xcode 9.2 as well as its respective command line tools:

                                 

                                xcode-select --install

                                 

                                I also attempted to use Xcode 9.3.1 and still experienced issues with the Simulator (iOS 11 versions only) seemingly continue to lag behind the same way Xcode 10.0 did.

                                 

                                Hope this provides some sort of solace for anyone experiencing this issue on macOS Mojave.

                                 

                                Haven't bothered to try Xcode 10 Beta 1 just yet as I'm sure the Simulator issues are twice as worse. Seems like Xcode 9.2 will just have to do for now in my case...

                                 

                                If you'd like, try to measure the compile times on Xcode by copying and pasting the following in your machine's terminal:

                                 

                                defaults write com.apple.dt.Xcode ShowBuildOperationDuration -bool YES

                                 

                                The above has also helped me to gauge how optimized my builds were or if they were laggy at all for any reason.

                                  • Re: XCode 10 simulator slow
                                    Jaffa Level 1 Level 1 (0 points)

                                    Thank You Alexandra, I think your comments have put me on the path to correction.

                                    Mojave ? huh? I believe that this and the dark mode is what is causing most of these SimulatorApp problems.

                                     

                                    After reinstalling way too many versions of iOS, I've found 9.3 most reliable for tableView scrolling etc.

                                    My Catch-22 is that  ":-1: WKWebView before iOS 11.0 (NSCoding support was broken in previous versions) [6]"

                                     

                                    Transition from 10.13.6 to 10.14.1 is going to put thousands of developer - users offside.

                                    The unusable view problems - scrolling - would seem to be a function of GPUs and more specifically Metal compatible GPUs.

                                     

                                    I understand the true black of oLED, vLED etc is attained by turning off a layer of molecules, ie. On 0x000000 or OFF (no electrons).

                                    Don't know whether this switching saves power, but makes sense why you might transition all your mobile devices to oLED.

                                     

                                    I call Apple's Dark Mode the darkside. Surely they wouldn't have done this purely for the gamers love of the dark aesthetic. Would they?

                                    Anyhow I don't like it. Might be able to dust off that old VT52 VDU with monochrome green display sitting at the back of garden shed.

                                     

                                    My perfectly functional iMac with partitioned SSD, circa 2012, does not fit the bill. If I read the release notes right, bootcamp also goes.

                                     

                                    Mojave compatibility details here.

                                     

                                    Hope this helps others.

                                     

                                    nb: By actually turning pixels off also improves contrast and readabilty of wearable devices when outside.

                                  • Re: XCode 10 simulator slow
                                    zy-mchen Level 1 Level 1 (0 points)

                                    same issue, **** slow...

                                    • Re: XCode 10 simulator slow
                                      alexandrafromatlanta Level 1 Level 1 (0 points)

                                      I ended up downloading Xcode 10.1 Beta & macOS Mojave 10.14.1 Beta which definitely improved performance and speed on my Simulators.

                                       

                                      Things seem to be in working order now and I don't have to result to using Xcode 9.2 (although I'll continue to use it on my other machine running High Sierra should I encounter any issues with this 10.1).

                                       

                                      For the time being, I will continue to document any issues should I encounter any but I am definitely pleased with the patch Apple provided for macOS Mojave 10.14.1 Beta which seems to work marvelously in conjunction with Xcode 10.1.

                                       

                                      Also, macOS Mojave 10.14.1 Beta has Group Facetime as a feature, so that's been really interesting to see. The Release Notes don't seem to have it documented for some reason..But Apple Insider casually mentions it along with other things that I'd expect to see in the Release Notes from Apple.

                                       

                                      So improvements I've noticed:

                                       

                                      • Indexing is faster
                                      • Simulators don't take forever to boot, even upon initial use.
                                      • Not as much lag as opposed to Xcode 10.0 GM
                                      • Load times are generally faster but not by much

                                       

                                      Overrall, keep your expectations low and hope for a GM fix soon.

                                      • Re: XCode 10 simulator slow
                                        iGore Level 1 Level 1 (0 points)

                                        Same **** here. MacBook Pro 17" Core i7, 4 physical cores + 4 logical, 16Gb RAM, 1Tb SSHD and **** simulator with 4-6fps

                                        • Re: XCode 10 simulator slow
                                          stucan Level 1 Level 1 (0 points)

                                          We have several mid-2011 27" iMac (3.4 GHz Intel Core i7) running High Sierra 10.13.6 with Xcode 10. All exhibit the same slow-down when trying to use the Simulator. If the Simulator is left running in the background the entire OS will eventually come to a halt until the Simulator is forcibly stopped.

                                           

                                          Seems to be slightly less of a problem on some newer Macs (e.g. mid-2017 MacBook Pro; mid-2013 27" iMac).

                                           

                                          Either way, it's making development for our team extemely difficult.

                                           

                                          Will try running ‘xcrun simctl diagnose’ and ‘sudo sysdiagnose -q’ when in this slowed state and attach the resulting tarballs to a bug report to see if that helps with any form of recognition / diagnosis.    

                                            • Re: XCode 10 simulator slow
                                              stucan Level 1 Level 1 (0 points)

                                              FYI - this workaround might help some of you in the meantime, but we've noticed that if you run the iPhone 5S / SE - 7, the slow-down is not as prevalent. Any newer devices are more or less unusable from the moment they open.

                                            • Re: XCode 10 simulator slow
                                              dobry73 Level 1 Level 1 (10 points)

                                              Start up times of my apps:

                                              iOS 10:  2 seconds

                                              iOS 11:  3 seconds !

                                              iOS 12:  4 seconds !!

                                              Also slow on iOS 12 device. SetImage: extremely slows down. When commenting them startup is fast.

                                               

                                              buttonPhoto setImage:[UIImage imageNamed:@"photoNormal7.png"]   forState:UIControlStateNormal];

                                               

                                              As a trial I removed assigning of images to UIButton from start-up and processed it after start-up separately, also on main-thread. Total 47 setImage: or setBackgroundImage: take 1 (iPhone SE) or even 2 seconds (iPhone 8 Plus) on iOS 12 simulator !!

                                               

                                                buttonPhoto.contentMode = UIViewContentModeCenter;
                                                [buttonPhoto setImage:[UIImage imageNamed:@"photoNormal7.png"]   forState:UIControlStateNormal];
                                                [buttonPhoto setImage:[UIImage imageNamed:@"photoDisabled7.png"] forState:UIControlStateDisabled];
                                                [buttonPhoto setImage:[UIImage imageNamed:@"photoDisabled7.png"] forState:UIControlStateDisabled|UIControlStateSelected];
                                                [buttonPhoto setImage:[UIImage imageNamed:@"photoSelected7.png"] forState:UIControlStateSelected];
                                                [buttonPhoto setImage:[UIImage imageNamed:@"photoHighlighted7.png"] forState:UIControlStateHighlighted];
                                                [buttonPhoto setImage:[UIImage imageNamed:@"photoHighlighted7.png"] forState:UIControlStateSelected|UIControlStateHighlighted];

                                               

                                              Setting of contentMode to center, so it shouldn't scale, didn't improve performance. The images exist as 1x, 2x, 3x (eg. photoNormal7.png, photoNormal7@2x.png, photoNormal7@3x.png).

                                               

                                              SOLUTION: Usage of image asset catalog (xcassets).

                                               

                                              Xcode 10 / 10.1 beta, macOS 10.14, MacBook Pro 13" 2018, 2.7GHz 4-Core, 16 GB

                                              • Re: XCode 10 simulator slow
                                                TrickeyD Level 1 Level 1 (0 points)

                                                Yeah this is crazy and needs sorting ASAP!

                                                 

                                                Is there an active bug / issue somewhere that i can +1?

                                                • Re: XCode 10 simulator slow
                                                  shsiehlnkd Level 1 Level 1 (0 points)

                                                  Having the same exact issue.

                                                   

                                                  The iOS 12 simulator is practically unsable.

                                                  • Re: XCode 10 simulator slow
                                                    cloudprogrammer Level 1 Level 1 (0 points)

                                                    Make sure you don't have slow animation turned on, Command + T or the debug menu.

                                                    • Re: XCode 10 simulator slow
                                                      akaBase Level 1 Level 1 (0 points)

                                                      Is there any official word from Apple about this or are they just attempting to get developers to fork out for the actual devices and or newer more powerfull and expensive devices to work from as with so many threads on this issue over so many different versions and years without it being addressed it sort of feels and looks like its intentional.

                                                      • Re: XCode 10 simulator slow
                                                        Gustavo@Cycloid Level 1 Level 1 (0 points)

                                                        Yeps, there's a scrolling insets (include inertia) lag / frozen problem since Xcode 9 (10 too) but only occurs on iPhone X/XS/XS Max Simulator.

                                                        • Re: XCode 10 simulator slow
                                                          neur0 Level 1 Level 1 (0 points)

                                                          When using macos 10.13.6 and xcode 10 on mac pro 5.1, starting the simulator it's getting so slow and lagging, that you cannot work. Also entire system is getting slow. Rolling back to xcode 9 woun't help. Only time machine helps. Rolled back to 10.13.4 and xcode 9. Tried xcode 10.1 beta, the problem still exists. Can't update this mac to Mohave because of Apple requires only cards with metall support((

                                                            • Re: XCode 10 simulator slow
                                                              iosmike Level 1 Level 1 (0 points)

                                                              I had the same problem with very slow simulator behavior on my Mac Pro 5.1 with XCode 10 (12 cores, 128GB RAM); simulator performance is fine on my Macbook Pro using XCode 10

                                                               

                                                              In order to upgrade to Mojave I swapped to a metal-capabile GPU (supplied a few years ago by a well-known flasher based in Hollywood) and that solved the problem (well, either the graphics card or the Mojave upgrade did)

                                                            • Re: XCode 10 simulator slow
                                                              sabrifromdev Level 1 Level 1 (0 points)

                                                              Same issue here with Xcode 10, High Sierra 10.13.6, Macbook Pro i7 with SSD

                                                              The simulator is unusable.

                                                              • Re: XCode 10 simulator slow
                                                                alexandrafromatlanta Level 1 Level 1 (0 points)

                                                                This has helped me in getting more performance improvements out of Xcode 10 but I just want to forewarn you all that I'm running macOS Mojave 10.14.1 beta 5 and Xcode 10.1 beta 3.

                                                                 

                                                                If those technical specs are not applicable to you, kindly disregard the following next steps I'll be presenting to squeeze more speed, optimal performance and efficiency out of your iOS Simulators running iOS 12 and above.

                                                                 

                                                                The reason why I specify these specs is because I've been downloading every single beta release since Mojave first came out and have been closely following each sequential release as a means of tracking which bugs have been addressed or fixed and if any beta release actually provides more optimal performance to my machine.

                                                                 

                                                                In this case, since we're discussing Xcode 10, let's begin:

                                                                 

                                                                • First order of business: get rid of Dark Mode altogether, you don't need it as much as you think you do. It's gimmicky and actually slows down your performance on Xcode in every shape and form. Notice that weird lag when you're trying to get your iOS Simulator going while simultaneouly browsing Chrome? That has definitely been attributed to Dark Mode in my case and I have seen a substancial difference in performance when running my apps on the Simulator.
                                                                • Turn off your device bezels by doing the following: Simulator > Window > Show Device Bezels (uncheck it if it checked by default).
                                                                • If you haven't already, be sure that you're slowing your animations: Simulator > Debug > Slow Animations
                                                                • Also, we're going to minize the quality of our graphics by doing the following:  Simulator > Debug > Graphics Quality Override > Low Quality (although Device Default works just as well, quite frankly. There is no literal difference graphically between Low Quality and Device Default. They both present themselves quite similarly).

                                                                 

                                                                Since applying the following changes to my Simulator preferences, indexing takes less effort out of Xcode, launching the Simulator itself is almost instananeous and app installation happens in seconds. While it's not the record speed that I'm used to from Xcode 7.3.1 or even Xcode 9.2, it makes version Xcode 10 a lot more usable than before I implemented some changes on machine settings.

                                                                 

                                                                Again, I haven't tested any of these changes on Xcode 10 GM so this could potentially help just about anyone even if they're not running macOS Mojave beta or even Xcode 10 beta versions. I simply wanted to emphasize that my machine could be different than yours in the aspect that I'm running beta software so implement these relatively harmless changes at your own discretion.

                                                                • Re: XCode 10 simulator slow
                                                                  El_Cid Level 1 Level 1 (0 points)

                                                                  I have the same issue... and I've been having it since Xcode 9 actually... I quickly decided to try the 10 beta hoping it was fixed.

                                                                  But nope - I have all the latest updates to Mojave and Xcode and the Simulator most of the time is unusanle. It takes multiple clicks (like 10-20) to perform an action like touch, and then it takes a few seconds to do the action. I don't know how to fix it - reminds me of Windows.

                                                                   

                                                                  This is on a 2017 13" MBP

                                                                  • Re: XCode 10 simulator slow
                                                                    mattn Level 1 Level 1 (10 points)

                                                                    Is the common factor "slightly older MacBook Pro"? That's what I've got, and the simulators are totally unusable. They are, oddly, somewhat better if Slow Animations are turned on, though then of course the simulation is not so realistic and everything takes longer.

                                                                    • Re: XCode 10 simulator slow
                                                                      Rich Levy Level 1 Level 1 (0 points)

                                                                      This is happening to me too.

                                                                       

                                                                      I have up to date Mojave, XCode & Simulator.  This is on MBP 2018.  Everything is new and the simular is unusable.

                                                                       

                                                                      My laptop sounds like its going to take off when I spin up the simulator.  Before XCode 10 I never had an issue.

                                                                       

                                                                      I've disabled dark mode and its still the same.

                                                                       

                                                                      Even using the simulator stand-alone without XCode its unusable.  I click on Safari and it often misinterprets the click and thinks I've held it for a long press.

                                                                      • Re: XCode 10 simulator slow
                                                                        AppleLuvr Level 1 Level 1 (0 points)

                                                                        I realize this is a late response, but I ran into this issue today and after searching on stackoverflow, I found that I had inadvertently pressed command+T, which triggers the "Slow Animations" (under the Debug menu in simulator). Pressing command+T again (or unselecting it in the menu) fixed the problem!

                                                                         

                                                                        (I have option+command+T set to be a keyboard shortcut for the simulator's Hardware->Touch ID->Matching Touch command, I missed the option key and just hit the command+T accidentally, it didn't log in to my app, so pressed option+command+T again, then logged in and everything was sooooo.... slooooowwwwwww....... I thought some of the new code I added to the app caused a major problem, but removing it didn't help—it didn't dawn on me that I had hit command+T accidentally prior to this happening, then I found the stackoverflow answer, unchecked "Slow Animations" from the Debug menu, and all is back to normal!) Hope it's this simple fix for others who run into this issue.

                                                                        • Re: XCode 10 simulator slow
                                                                          gugapc Level 1 Level 1 (0 points)

                                                                          Maybe you have put your debug in slowly animation.

                                                                          Go to: Debug > Slow Animations

                                                                          or

                                                                          Try this ⌘T

                                                                          • Re: XCode 10 simulator slow
                                                                            jeremyhu Apple Staff Apple Staff (160 points)

                                                                            The core issue here is that older versions of the simulator use the CPU for rendering.  iOS 13 running on Catalina will utilize the GPU through Metal.  You should have a much better experience with this year's releases.