17 Replies
      Latest reply on Sep 23, 2018 3:02 PM by Cragus
      Cragus Level 1 Level 1 (0 points)

        Hello everyone,

         

        So I am a Primary Teacher with no coding experience but I would (eventually) like to develop a simple app to help teach phonics in my class. I have literally no coding experience and I have started to learn with CodewithChris tutorial videos on youtube. I have been doing ok at following along with these videos so far

         

        However, my simulator is slow as treacle (probably as my macbook pro is late 2011 with 8GB) so I  have been trying to get builds to run on my device (iphone 7 plus). The simple card game I made up said build suceeded on simulator but not the device. I made a new program with simply 2 images in it on the storyboard to see it I could make it run and I am still having issues.

         

        I am using xcode 10 - am i doing something really silly?

         

         

        Showing Recent Issues

        CopySwiftLibs /Users/CB/Library/Developer/Xcode/DerivedData/tryout-gglolnphjcrporczheotssazrnqq/Build/Products/Debug-iphoneos/tryout.app (in target: tryout)

            cd /Users/CB/Desktop/MagneticBoard\ Project/tryout

            export CODESIGN_ALLOCATE=/Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/codesign_allocate

            export DEVELOPER_DIR=/Applications/Xcode.app/Contents/Developer

            export SDKROOT=/Applications/Xcode.app/Contents/Developer/Platforms/iPhoneOS.platform/Developer/SDKs/iPhoneOS12.0.sdk

            builtin-swiftStdLibTool --copy --verbose --sign C5801F11EE70041A3EB2315AA69C8FF0C3D9F793 --scan-executable /Users/CB/Library/Developer/Xcode/DerivedData/tryout-gglolnphjcrporczheotssazrnqq/Build/Products/Debug-iphoneos/tryout.app/tryout --scan-folder /Users/CB/Library/Developer/Xcode/DerivedData/tryout-gglolnphjcrporczheotssazrnqq/Build/Products/Debug-iphoneos/tryout.app/Frameworks --scan-folder /Users/CB/Library/Developer/Xcode/DerivedData/tryout-gglolnphjcrporczheotssazrnqq/Build/Products/Debug-iphoneos/tryout.app/PlugIns --platform iphoneos --toolchain /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain --destination /Users/CB/Library/Developer/Xcode/DerivedData/tryout-gglolnphjcrporczheotssazrnqq/Build/Products/Debug-iphoneos/tryout.app/Frameworks --strip-bitcode --resource-destination /Users/CB/Library/Developer/Xcode/DerivedData/tryout-gglolnphjcrporczheotssazrnqq/Build/Products/Debug-iphoneos/tryout.app --resource-library libswiftRemoteMirror.dylib --strip-bitcode-tool /Applications/Xcode.app/Contents/Developer/Toolchains/XcodeDefault.xctoolchain/usr/bin/bitcode_strip --emit-dependency-info /Users/CB/Library/Developer/Xcode/DerivedData/tryout-gglolnphjcrporczheotssazrnqq/Build/Intermediates.noindex/tryout.build/Debug-iphoneos/tryout.build/SwiftStdLibToolInputDependencies.dep

         

         

        error: Failed with exit code 1

        • Re: Running xCode 10 on device error
          Claude31 Level 8 Level 8 (6,515 points)

          What is the IOS version on your iPhone ?

           

          Have you set the target in XCode accordingly ?

          - select the program name at the top of the project navigator (left pane of XCode)

          - select the Project

          - Look at deployment target and check that it is anterior to your iPhone's IOS version

            • Re: Running xCode 10 on device error
              Cragus Level 1 Level 1 (0 points)

              Thanks Claude,

               

              I am running iOS12 on my phone.

               

              In the toolbar, I have chosen my phone from under the heading Device. I didn't see an option for iOS version.

                • Re: Running xCode 10 on device error
                  Claude31 Level 8 Level 8 (6,515 points)

                  If IOS is version 12, no need to check for XCode target.

                   

                  However, if you want to see the target :

                  - in the left pane, below the 6 smal icons (including the search icon), you have a file name with a blue icon (your app name)

                  - select it

                  - then select the Project name

                  - and select Info tab (not Build settings)

                  - the deployment target appears first.

                   

                  Did you do a clean Build Folder (Product menu of XCode) ?

                    • Re: Running xCode 10 on device error
                      Cragus Level 1 Level 1 (0 points)

                      Thanks again,

                       

                      I reselected 12.0 as the deployment target and did a clean build. The program is literally just an image at the moment until I can ensure I can run it.

                       

                      Still not working?

                        • Re: Running xCode 10 on device error
                          Claude31 Level 8 Level 8 (6,515 points)

                          Could you check your signing settings :

                           

                          - in the left pane, below the 6 smal icons (including the search icon), you have a file name with a blue icon (your app name)

                          - select it

                          - then select the TARGETS name

                          - and select General tab

                          - Signing settings appears second.

                           

                          Another check.

                          I  have been trying to get builds to run on my device (iphone 7 plus)

                          - So you connected your iPhone with USB cable ?

                          - and selected it as the target at the very top in XCode ?

                  • Re: Running xCode 10 on device error
                    KMT Level 9 Level 9 (14,655 points)

                         >no coding experience but I would (eventually) like to develop a simple app

                     

                    Sorry if I missed it - do you have a paid Developer Program account or are you attempting to use Xcode's 'free provisioning'?

                     

                    Have you been able to build any apps to any device, so far?

                      • Re: Running xCode 10 on device error
                        Cragus Level 1 Level 1 (0 points)

                        Attempting to use free provisioning. I only started to learn swift/xcode yesterday with no other experience so was holding off on paying until I have something to show for it.

                         

                        I managed to build my first view tutorial lessons onto a simulator. I haven'e been able to build to my phone at all. I'm about to try an ipad mini.

                         

                        P.s. Failed with exit code 1 is the other error message.

                          • Re: Running xCode 10 on device error
                            Cragus Level 1 Level 1 (0 points)

                            My accout says:

                             

                            Provisioning Profile - Xcode Managed Profile

                            • Re: Running xCode 10 on device error
                              KMT Level 9 Level 9 (14,655 points)

                                   >Attempting to use free provisioning

                               

                              In that case, there is a chance you're following something that assumes a paid account, risking confusing over the process -  see this thread [how i can have free Developer Program ] with an already moderated link that explains Xcode's free provisioning process (with screenshots) - be sure to read all the way thru it and any updates at the bottom.

                               

                              As well, it might help your understanding to create a new project using Xcode's SimpleView template, with no changes, then build to your device. Once that works, go back to your original project and compare settings as needed, then go again with it.

                               

                              Good luck.

                                • Re: Running xCode 10 on device error
                                  Cragus Level 1 Level 1 (0 points)

                                  Thanks KMT,

                                   

                                  Everthing appears to be correct. However in

                                   

                                  Preferences > Accounts > Manage certificates

                                   

                                  it says there is a missing private key next to my macbook pro although my  macbook appears to be listed twice.

                                   

                                  I tried removing my apple ID then add it again. Same issue. Could this be the cause?

                                    • Re: Running xCode 10 on device error
                                      KMT Level 9 Level 9 (14,655 points)

                                      What happens if you create a new project, no changes, and try to build it to your device?

                                       

                                           >it says there is a missing private key next to my macbook pro although my  macbook appears to be listed twice.

                                       

                                      Ignore when using free provisioning.

                                        • Re: Running xCode 10 on device error
                                          Cragus Level 1 Level 1 (0 points)

                                          Started a new project - change nothing - still getting a failed with exit code 1.

                                            • Re: Running xCode 10 on device error
                                              KMT Level 9 Level 9 (14,655 points)

                                              When you use Xcode/Target/General/Signing/Team...any complaints/errors/red text/offers to repair, there, when selecting your name (personal) team?

                                               

                                                   >Failed with exit code 1

                                               

                                              That's it? Nothing about code signing?

                                                • Re: Running xCode 10 on device error
                                                  Cragus Level 1 Level 1 (0 points)

                                                  It's definately something to do with certificates I think.

                                                   

                                                  I deleted all certicates and files from the keychain - problems looks worse now haha

                                                   

                                                  I deleted my apple ID and then readded.

                                                   

                                                  Now getting

                                                  Xcode couldn't find any iOS App Development provisioning profiles matching 'com.CB.Testingapp'.

                                                  The user name or passphrase you entered is not correct.

                                                   

                                                   

                                                  Still have the missing private keychain in certiciates.

                                                    • Re: Running xCode 10 on device error
                                                      KMT Level 9 Level 9 (14,655 points)

                                                           >something to do with certificates

                                                       

                                                      Using free provisioning does not allow you access to the related area of the Member Center/Certificates, Identities and Profiles. No access means no control.

                                                       

                                                      If you're poking around on the 'net for hints, you may eventually succeed just by stumbling around in the dark, but again, conflating paid account provisioning tips w/free is strictly a rabbit hole. Be careful out there.

                                                       

                                                      Good luck.

                                                      • Re: Running xCode 10 on device error
                                                        Claude31 Level 8 Level 8 (6,515 points)

                                                        So may be you should consider if paying $99 for developer paid account is worth the value (with regard to the time you risk loosing otherwise).