24 Replies
      Latest reply on Jun 18, 2018 7:44 PM by kevleyski
      Taylor E Level 1 Level 1 (0 points)

        Hi there,


        I am hoping someone might know how to fix this - after updating to High Sierra, the two admin accounts on this machine are all of a sudden standard accounts. There is no admin account at all, which means I can't seemingly fix this problem because there is no admin I can log into. Any changes to the system or software installs I try to do that require admin approval, I have no way to grant it. And no way to create a new admin user without an existing.


        I've looked up a couple of ways around this, but none have worked so far (example, using the command resetpassword while in recovery mode in terminal - it no longer allows you to select the root - it only shows the two Standard account - no way to create an admin. Also tried "resetting" the setup so I would reboot and have to go through setup again, forcing the system to allow me to create a new user through the setup process, but High Sierra doesn't go through those steps.)


        Anyone have any ideas on what to try? There's always wiping the entire system, installing a fresh copy, setting up a detault user, and then importing the old users - but I thought I would see if anyone here could save me some time with some simple commands