79 Replies
      Latest reply on Apr 3, 2018 11:27 AM by mroseCB
      theeternalsw0rd Level 1 Level 1 (10 points)

        Is it just me or is the telnet client no longer present in macOS High Sierra? There doesn't appear to be an open source drop in replacement that works out of the box, and telnet + libtelnet combination from opensource.apple.com doesn't appear to work out of the box either. I think the telnet package that gentoo uses could be patched to work, but wanted to see if anyone wanted to weigh in here first before I spend too much time on that.

        • Re: where did telnet go? (10.13 preview)
          mrgnw Level 1 Level 1 (0 points)

          Not just you.


          It is at /usr/bin/telnet on my Mac with 10.11, but it is not there for me in 10.13


          Another thread recommends Using ssh and sftp instead.


          As a temporary solution I just copied the telnet file from my other machine.

            • Re: where did telnet go? (10.13 preview)
              jmorby Level 1 Level 1 (0 points)

              there is nc (netcat?) ... which is like telnet


              I haven't yet found a workaround for the lack of ftp (other than to build/install ncftp I guess)


              This is a definite retrograde step on Apple's part

                • Re: where did telnet go? (10.13 preview)
                  NotMyName Level 4 Level 4 (875 points)

                  There's a pretty huge list of "work arounds" concerning the lact of ftp, but they all involve a lecture concerning the lack of security in ftp and a list of the various alternate protocols that could be getting used.  If you're using ftp for anonymous ftp, that's better done using HTTP.  If you're using ftp for other things, you're better off using sftp, scp, or something similar. 


                  To be blunt, I'd expect a networking person to look at you like you were asking about Gopher support if you complained about the lack of an ftp client.  :-/

                    • Re: where did telnet go? (10.13 preview)
                      CordovaBay Level 1 Level 1 (0 points)

                      The problem is some programs using ftp to access data located in servers controlled by 3rd parties.


                      Does ftp support via PHP work? Is that a native implementation or does it use the standard Unix tools?

                        • Re: where did telnet go? (10.13 preview)
                          NotMyName Level 4 Level 4 (875 points)

                          If you've got some reason that you need ftp (or telnet), file a bug report in the bug reporter.  Those get read and tabulated, not forum posts.


                          YOu can check the PHP source code if you've got questions about how it implements ftp.  But given that there's no configuration options that I can see for the ftp module (where'd you have to specify the external path, for instance) I'd assume it's its own implementation.

                        • Re: where did telnet go? (10.13 preview)
                          thethor Level 1 Level 1 (0 points)

                          FWIW - 25 year of systems and network management, masters degree in C.S. and I'd call anyone who doesn't see the immediate value of the telnet *cllient* for debugging purposes and legacy support a rambling idiot (pardon my French).


                          The decision to drop the telnet client from OS X (no, I refuse to call it "MacOS" since that's the 8-bit mishmash that ran the Macintosh) is utter lunacy. Although a graphics designer may _never_ have to operate the command line, let alone telnet, a lot of C.S. and I.T. professionals have bought into the Apple OS X platform. These individuals deserve the ounce of respect their dollar worth is.


                          From my observations, Apple has been in the dark hours of Tim Cook been nudging the Apple OS X platform steadily towards the design of the black box iPad. And for every little nudge (dropping telnet is one) I get more inclined to install Linux on my MBP.

                            • Re: where did telnet go? (10.13 preview)
                              Thor_HoG Level 1 Level 1 (0 points)

                              You are absolutely correct, sir.   Removing telnet and ftp bash clients from High Sierra was a mistake, not withstanding the ramblings of others.  The same is true for Microsoft's move to require telnet and ftp clients to be installed as a "feature" when they attempted to mitigate security issues by doing so.  In a large degree, they still don't seem to understand security.  Oddly enough, tftp still works on HS.  Go figure.


                              One can copy telnet and ftp over from a Sierra /usr/bin to High Sierra /usr/local/bin and it works fine.  Be sure to chmod +xr both after the copy (using sudo).  Much easier than downloading other versions, etc. 



                              • Re: where did telnet go? (10.13 preview)
                                EasyGoing1 Level 1 Level 1 (0 points)



                                THANK YOU for that!  I also have been a network engineer for 25 years and have been using OSX for at least the last 12 of those years and have become quite dependent on terminal as my primary gateway for all things analysis and troubleshooting. Tonight, I need to telnet into a cisco switch that does not offer SSH because it's too old. Serial is an option, but a pain in the rear... Apple dropping telnet from terminal is 1) Rediculous 2) Unnecessary and 3) Deliberately cruel??? I know Apple loves to drive change through corporate communist policies, but youd think they could back off on a couple hundred k of drive space for those of us who not only use their product, but are also walking advertisements for their product everywhere we go...


                                So much for brand loyalty I suppose ...


                                Have a great holiday season my friend!



                                • Re: where did telnet go? (10.13 preview)
                                  andmat2017 Level 1 Level 1 (0 points)


                                  youre absolutely right.

                              • Re: where did telnet go? (10.13 preview)
                                rick sustek Level 1 Level 1 (0 points)

                                To elaborate, when using nc to connect to a server that is a "telnet server" (and generally listens on port 23),

                                the options -c and -t may help it work better.


                                Whether nc can fully replace telnet against a specific server, depends on what the specific server is implemeting. Examples:

                                • attempting to test against one of the many protocols out there that are essentially line mode oriented, with ASCII charset, will typically be just fine with nc, and maybe adding the -c flag to use the "CRLF" line terminators. HTTP and SMTP fall into this category.
                                • Attempting to test against an actual telnet protocol server may not work with nc, depending on the implementation. This gets into the "line mode" issues, and character echo issues of the server side. Don't forget there are many embedded devices out there (what you youngins like to call IOT devices), which provide a "telnet" service interface. Such devices do not necessarily support the negotiation aspects of the full telnet specification, and thus may be rigid in what they expect from the connecting client. The use of the -t option to nc may solve this problem, or it may not.
                              • Re: where did telnet go? (10.13 preview)
                                cerniuk Level 1 Level 1 (0 points)

                                Just copied telnet from my Sierra box (/usr/bin/telnet) over to High Sierra (/usr/local/bin) and it works fine.  Used it to test the extended hello protocol repsonse from Apple's iCloud email SMTP server.  (can't do that with SSH).


                                Filed Apple Bug Report 33917965 Telnet Missing High Sierra 10.13b5


                                In the event that you don't have it, I pulled it from my Apple server and zipped it here:


                              • Re: where did telnet go? (10.13 preview)
                                markbyrn Level 1 Level 1 (0 points)

                                I use Telnet everyday and so I jumped over hoops to copy it over from my Sierra machine and posted a bugreporter "suggestion" to put it back.

                                  • Re: where did telnet go? (10.13 preview)
                                    paul_at_tahoe Level 1 Level 1 (0 points)

                                    Can you ssh from terminal instead of using telnet? Way more secure....

                                      • Re: where did telnet go? (10.13 preview)
                                        sirdir Level 1 Level 1 (0 points)

                                        telnet is good for debugging things, telnet xxx 25, telnet xx 80 ... telnet xxx 443 ...

                                        • Re: where did telnet go? (10.13 preview)
                                          mebibyte Level 1 Level 1 (0 points)

                                          Why should one want to use ssh instead of telnet? It's totally different use-cases. I don't want a telnet shell, but I want to debug my mailserver using telnet and check other services on the servers I have to administrate and telnet is THE tool for me to do that. As a server admin, I cannot live without telnet and I use a Mac because it gives me Linux power with the "it just works" environment. Pretty crappy, if these tools go away.


                                          By the way - I have 25 years experience in software development and hold a PhD in computer science, so I think I know what I talk about. Anyhow - it's ridiculous that there is even a discussion about "why don't you now do x instead of a", while a was around always and someone now decided to drop it, obviously without knowing what he or she does. We shouldn't discuss dirty workarounds and alternatives but just get telnet back. Period.

                                          • Re: where did telnet go? (10.13 preview)
                                            Crawdad Level 1 Level 1 (0 points)

                                            It is a common bit of naivete to think that ssh is more secure than telnet. Sure, telnet is usually used insecurely, but it doesn't have to be. My site supported telnet logins for many years with a higher security than ssh. Here's the explanation ...


                                            Telnet doesn't have to be clear-text, it can be encrypted. And it doesn't have to send passwords, it can use nondisclosing authentication. So a telnet daemon configured for, say, Kerberos v5 authentication and mandatory session encryption was *more* secure than ssh, because ssh was still having one security bug after another for a long time. Telnet was far simpler code, and more mature. It had only one security bug that I recall, if certain extensions were added, and it required users to authenticate.

                                          • Re: where did telnet go? (10.13 preview)
                                            Yaybe Level 1 Level 1 (0 points)

                                            Hi, where is it located?

                                            • Re: where did telnet go? (10.13 preview)
                                              cerniuk Level 1 Level 1 (0 points)

                                              Telnet is an incredibly useful tool to quickly determine if just about anything is responding on any port. It is a ping with attitude for debugging.


                                              Can't believe Apple remove this very standard basic UNIX tool. Insanely Great san great.

                                            • Re: where did telnet go? (10.13 preview)
                                              john daniel Level 4 Level 4 (700 points)

                                              Go to "www.gnu.org/software/inetutils/" (full URL omitted to avoid moderation)

                                              Click on the HTTP download link for "Inetutils"

                                              Download "inetutils-1.9.4.tar.gz"

                                              tar zxvf inetutils-1.9.4.tar.gz

                                              cd inetutils-1.9.4



                                              sudo make install

                                              telnet rainmaker.wunderground.com



                                              • Re: where did telnet go? (10.13 preview)
                                                Ksog Level 1 Level 1 (0 points)

                                                Telnet is removed in high sierra due to its a 32bit program . I use ssh now.

                                                • Re: where did telnet go? (10.13 preview)
                                                  HighlyExperienced Level 1 Level 1 (0 points)

                                                  Use the which command to find where a command is located.  Many of the UNIX commands are supplied by Apple in /usr/bin, which should be in your path.  It looks like my copy of /usr/bin/telnet is relatively recent, so I assume that it was in the last OS release.  If you add your own telnet, you also have to check the order of the directories to make sure that you are using the correct code.  Many items in /usr/bin are actually links to files in other directories.  Do echo $PATH to see how your console is set up.


                                                  BradleyRossMacBook:~ bradleyross$ which telnet




                                                  BradleyRossMacBook:~ bradleyross$ ls -l /usr/bin/telnet


                                                  -r-xr-xr-x  1 root  wheel  117008 Mar 22 19:57 /usr/bin/telnet


                                                  BradleyRossMacBook:~ bradleyross$ ls -l /usr/bin/java


                                                  lrwxr-xr-x  1 root  wheel  74 Jun  4 13:48 /usr/bin/java -> /System/Library/Frameworks/JavaVM.framework/Versions/Current/Commands/java


                                                  BradleyRossMacBook:~ bradleyross$

                                                  • Re: where did telnet go? (10.13 preview)
                                                    cerniuk Level 1 Level 1 (0 points)

                                                    Still shows in the Terminal interface as an option in High Sierra...




                                                    (are they ever going to fix the image upload in this forum software!?)

                                                    • Re: where did telnet go? (10.13 preview)
                                                      tomgidden Level 1 Level 1 (0 points)

                                                      While I agree it's not a bad idea to deprecate these insecure standard utilities by removing them from the standard install, they're still sometimes necessary when working with embedded stuff for IoT, as well as the occasional router.



                                                      brew install inetutils

                                                      seems to work, installing `/usr/local/bin/telnet` and `ftp`, as well as the old favourites `rlogin`, `rsh`, `rcp`...

                                                        • Re: where did telnet go? (10.13 preview)
                                                          ylluminate Level 1 Level 1 (0 points)

                                                          Removing these programs from the standard install has no justification whatsoever. They will eventually have to be used and forcing users to download and install someone else's coreutils is just outrageous.




                                                          Also I just tried using the GNU inetutils and they are buggy on OS X. Which is no surprise, they aren't meant for this system which makes removing the BSD ones even more ludicrous.

                                                        • Re: where did telnet go? (10.13 preview)
                                                          adreyer Level 1 Level 1 (0 points)

                                                          If you've used telnet for basic connectivity tests, consider nc (netcat) instead.


                                                          Look how much easier nc is than telnet to see if I can reach port 2195 on gateway.push.apple.com.


                                                          nc -z gateway.push.apple.com 2195

                                                          Connection to gateway.push.apple.com port 2195 [tcp/] succeeded!



                                                          telnet gateway.push.apple.com 2195


                                                          Connected to gateway.push-apple.com.akadns.net.

                                                          Escape character is '^]'.


                                                          telnet> q

                                                          Connection closed.

                                                            • Re: where did telnet go? (10.13 preview)
                                                              ekrub Level 1 Level 1 (0 points)

                                                              Upgraded to High Sierra today and already miss telnet.


                                                              My needs for telnet went a little beyond basic connectivity tests. I needed to send a command. Fortunately, nc (netcat) can do a simple command as well. I was able to replace this:


                                                              echo "some command" | telnet example.com 12345


                                                              with this:


                                                              echo "some command" | nc -c example.com 12345
                                                            • Re: where did telnet go? (10.13 preview)
                                                              ylluminate Level 1 Level 1 (0 points)

                                                              I sure hope this change is temporary and that these standard utilities will be back once 10.13 is out of beta. It would be utter folly to remove these utilities, regardless of their "insecurity." To be honest, whoever uses these protocols without the knowledge that they are insecure has no business using networking utilities at all. I mean, for goodness sake, I thought it was well known that not every host has the luxury of running `sshd'.




                                                              These programs are absolutely necessary. Removing them is tantamount to removing all doors without locks because locked doors are "better."

                                                                • Re: where did telnet go? (10.13 preview)
                                                                  iTen Level 2 Level 2 (80 points)

                                                                  Brew is your friend, now pour yourself a pint of telnet using "brew install telnet" or install brew first.


                                                                  Drink up!

                                                                    • Re: where did telnet go? (10.13 preview)
                                                                      napabar Level 1 Level 1 (0 points)

                                                                      OK, I got Brew and downloaded Telnet.  As a client, it works fine.


                                                                      Now, how do I enable telent server under High Sierra?  The following old instructions no longer work.



                                                                      anand$ sudo launchctl


                                                                      launchd% load -F /System/Library/LaunchDaemons/telnet.plist

                                                                      launchd% exit

                                                                      • Re: where did telnet go? (10.13 preview)
                                                                        ylluminate Level 1 Level 1 (0 points)

                                                                        As napabar explained, only the telnet client is available in homebrew. No server. Plus, what about ftp, rsh, rcp, etc.? Don't just say to use the the GNU inetutils, as they can be buggy on OS X. No surprise; they are hardly ever used on this system. Now people basically have no alternative. Not to mention that the last stable release of it was in 2015.


                                                                        Frankly, Apple has no excuse for removing these tools. Pushing ssh is pointless; the reason that people don't use ssh is NOT because there are alternatives available. The reasons that people don't use ssh are typically one of:


                                                                        1. they have no choice, or
                                                                        2. encryption is NOT needed or wanted in their use case


                                                                        Trying to force ssh down people's throats is not going to work. There are simply places where ssh can't go, shouldn't go, or isn't allowed to go.


                                                                        Yeah, despite popular belief, locking everything up is not always needed. Again, it's a real shame that Apple always pushes stupid agendas like this for no real reason. It's just pointless and painful. But when has Apple cared about forcing people to go through pointless and painful changes, after all?


                                                                        Maybe all this sounds hard on Apple. But take a step back and ask yourself: does it hurt a multi-billion dollar company to just let their developers and power-users have what they want / need? Of course not. They just either get a rush out of controlling their customers and / or they convince themselves of stupid reasons as to why that's a good thing.


                                                                        By the way, I'm not angry at you, iTen. I'm just saying the homebrew is unfortunately not sufficient for this issue. And I'm angry that Apple forces people to jump through these pointless hoops just to get some needed functionality.

                                                                    • Re: where did telnet go? (10.13 preview)
                                                                      okand Level 1 Level 1 (0 points)

                                                                      I freaked out about this too but then a coworker told me I can test for listening ports with netcat (nc).


                                                                      It's much cleaner, you can exit it with ctrl+c instead of having to change to a keyboard layout that has [ on its own key without modifiers just to be able to do the escape sequence.

                                                                      • Re: where did telnet go? (10.13 preview)
                                                                        ebeaudry Level 1 Level 1 (0 points)

                                                                        You can create a simple script to replace telnet with installed nc command:

                                                                        sudo echo '#!/bin/bash' > /usr/local/bin/telnet
                                                                        sudo echo 'nc -c $@' >> /usr/local/bin/telnet
                                                                        sudo chmod 755 /usr/local/bin/telnet
                                                                        • Re: where did telnet go? (10.13 preview)
                                                                          alexeychik Level 1 Level 1 (0 points)

                                                                            "sudo brew install terminal" does the trick. You need to have Homebrew installed.

                                                                            • Re: where did telnet go? (10.13 preview)
                                                                              AnthonyNYC Level 1 Level 1 (0 points)

                                                                              This is part of a very calculated strategy that Apple has. I think you are under the (wrong) impression that OS X somehow is friendly to Developers/Technology people. This hasn't been Apple's focus in nearly a decade. Recently they have switched from being merely neutral to openly hostile. They don't want your money. You aren't welcome on their platform. You can take your nerdy tools and take them somewhere else. I'm not sure why anyone would be surprised by this. Video Editors got the message years ago and moved on, yet us, developers somehow are lingering on. OS X is now for sharing pictures of cats and browsing Facebook. Have you tried Vim in touchbar macbooks? I rest my case.

                                                                              • Re: where did telnet go? (10.13 preview)
                                                                                xnsys Level 1 Level 1 (0 points)

                                                                                There's always ZOC I suppose.

                                                                                • Re: where did telnet go? (10.13 preview)
                                                                                  AP1399 Level 1 Level 1 (0 points)

                                                                                  Another possible fix:

                                                                                  If running MacPorts, install 'inetutils'. It contains telnet.

                                                                                  • Re: where did telnet go? (10.13 preview)
                                                                                    Truenorth49 Level 1 Level 1 (0 points)

                                                                                    I was able to restore Telnet from the Time Machine

                                                                                    In Finder's Go menu select Go to Folder...

                                                                                    In the window that opens enter "/usr/bin"


                                                                                    Now open Time Machine and go back to a time before 10.13 was installed

                                                                                    Find Telnet and ask to restore it to <some folder>

                                                                                    I found that it restored the whole /usr/bin folder but it is small

                                                                                    • Re: where did telnet go? (10.13 preview)
                                                                                      Dysolv Level 1 Level 1 (0 points)

                                                                                      All of the workarounds listed here seem to work, except when clinking a telnet: link in a browser. This, for whatever reason, seems not to follow the PATH which will see the brew/port/alias in /usr/local/bin folder


                                                                                      When clicking the telnet: link in a brower I get the following error in iTerm2:

                                                                                      Failed to exec telnet: No such file or directory


                                                                                      When using macs native Terminal app I get this:

                                                                                      [Command not found: telnet]
                                                                                      [Could not create a new process and open a pseudo-tty.]
                                                                                        • Re: where did telnet go? (10.13 preview)
                                                                                          Damien@FR Level 1 Level 1 (0 points)

                                                                                          Same issue.


                                                                                          Telnet command works fine from the command line but I'm unable to launch it from a "telnet://" URL within a browser.


                                                                                          Tested with Safari and Firefox.


                                                                                          Anyone successfully changed the PATH used by the terminal launched from a browser ?


                                                                                          .bashrc and .bash_profile don't seem to be effective :

                                                                                          • they change the PATH from a "standard" terminal session
                                                                                          • the PATH of a terminal session launched by the browser is unmodified : PATH=/usr/bin:/bin:/usr/sbin:/sbin
                                                                                        • Re: where did telnet go? (10.13 preview)
                                                                                          danieletorelli Level 1 Level 1 (0 points)

                                                                                          A possible quick fix if you have HomeBrew installed:


                                                                                          brew install telnet


                                                                                          And enjoy

                                                                                          • Re: where did telnet go? (10.13 preview)
                                                                                            amptec Level 1 Level 1 (0 points)

                                                                                            To another workaround take a look at




                                                                                            There you can find a step by step to solve that.

                                                                                            • Re: where did telnet go? (10.13 preview)
                                                                                              PeteLong Level 1 Level 1 (0 points)

                                                                                              Heres how to put it back (and FTP)


                                                                                              Mac High Sierra – Telnet and FTP Missing? (link below)



                                                                                                • Re: where did telnet go? (10.13 preview)
                                                                                                  maverickws Level 1 Level 1 (0 points)

                                                                                                  curl -v telnet://ip:port


                                                                                                  the same for ftp protocol


                                                                                                  I get utterly surprised with the ammount of garbage u people like to put on your macs. I wonder if anybody is going back at FreeBSD kernel v. 1

                                                                                                  looks like the people removing netowrk manager from RHEL to install iptables. I mean, people, move on!


                                                                                                  No harm inteded with this reply. Cheers.


                                                                                                • Re: where did telnet go? (10.13 preview)
                                                                                                  RobertoES Level 1 Level 1 (0 points)

                                                                                                  This *****...

                                                                                                  • Re: where did telnet go? (10.13 preview)
                                                                                                    maverickws Level 1 Level 1 (0 points)

                                                                                                    Hey ppl so after seeing all your replies I just wanted to point the most simple solutions.


                                                                                                    nc -vz ip port as so many people refered; or


                                                                                                    curl -v telnet://ip:port


                                                                                                    as simple as it gets.




                                                                                                      • Re: where did telnet go? (10.13 preview)
                                                                                                        acruhl Level 1 Level 1 (0 points)

                                                                                                        If you need tab completion and the ? to work, like in network devices, I found this elsewhere on the net (with a tweak):


                                                                                                        stty -echo -icanon && nc x.x.x.x 23 ; stty sane


                                                                                                        Make that into a script and take $1 as an argument for the IP and you have a pretty good approximation of a telnet client.

                                                                                                      • Re: where did telnet go? (10.13 preview)
                                                                                                        jerryfrit Level 1 Level 1 (0 points)

                                                                                                        I did the "brew install inetutils" myself.


                                                                                                        But libcurl is also built into macOS, and I believe you can do "curl telnet://"

                                                                                                        • Re: where did telnet go? (10.13 preview)
                                                                                                          RouterHax0r Level 1 Level 1 (0 points)

                                                                                                          If you install telnet from previous version (time machine) or via brew.  You will need it to be in the /usr/bin directory.  Using the /opt/local/bin directory will work if you only use command line telnet via $PATH but will break any  telnet URLs.


                                                                                                          For example  open terminal and typing telnet will work.


                                                                                                          Clicking on a link pointing to telnet:// will not work UNLESS the telnet utility is in the /usr/bin directory.


                                                                                                          HOWEVER... you cannot modify the /usr/bin directory until you have SIP disabled on your system.

                                                                                                          • Re: where did telnet go? (10.13 preview)
                                                                                                            janv Level 1 Level 1 (0 points)

                                                                                                            To solve this kind of problems, like slightly different behavior of Linux-like tools or command line stuff that goes missing, I use a Docker container:


                                                                                                            FROM ubuntu:latest
                                                                                                            RUN apt-get update
                                                                                                            RUN apt-get install -y telnet net-tools

                                                                                                            Save this in a file named Dockerfile, then enter


                                                                                                            docker build . -t tools


                                                                                                            and finally


                                                                                                            docker run -it tools /usr/bin/telnet


                                                                                                            you could create an alias to get telnet back the way it was before. I've added this line to ~/.zshrc:


                                                                                                            alias telnet="docker run -it tools /usr/bin/telnet"
                                                                                                            • Re: where did telnet go? (10.13 preview)
                                                                                                              ylluminate Level 1 Level 1 (0 points)

                                                                                                              Apple's Telnet and FTP are back in this homebrew pull request. That includes both the server and client of each one.

                                                                                                              • Re: where did telnet go? (10.13 preview)
                                                                                                                rb3rg Level 1 Level 1 (0 points)

                                                                                                                I started in the IT back in 90's when Linux was kernel 1.X skinny like Linus was LOL.

                                                                                                                In 2000 I finely quit windows on my working laptop to become a full time Linux user because I loved the *unix freedom.

                                                                                                                In 2008 I fallen in love with the amazing Apple macbook hardware and the fancy GUI while keeping most of all my *unix stuff I need.

                                                                                                                The price was higher than a normal good PC laptop but not more than twice.


                                                                                                                Then comes Apple with this communist ideas of control what people can / can't do driving people idiots and brainless.

                                                                                                                I'm not going to write down everything what I think about what Apple is doing 'cause it will come down to a long text.


                                                                                                                Now days to purchase a descent workable “non-upgradable” Macbook we have to spend 3 to 4 x more than a really good PC laptop and live with the Apple communist control idea. What is the next step? remove the terminal it self?


                                                                                                                So, time to switch to Linux again. Ahh, before I forget, I gave up iPhone after the 3G. Love my Android custom rom, freedom is so awesome and I don't have to take the "battery Performance issue case" like an idiot.

                                                                                                                Bye bye Apple. I here and now apply for a divorce.


                                                                                                                "Just one of the Opinion Makers who helped you to sell many macbooks in the last 10 years"