5 Replies
      Latest reply on Sep 26, 2017 7:20 AM by dingzzzzli
      atl_chris Level 1 Level 1 (0 points)

        I upgraded my 13" MacBook Pro (the first model with the touch bar) today from Sierra to the newest High Sierra Beta. My SSD has FIleVault turned on.

         

        After rebooting, when I enter my password to unlock the hard drive, it shakes no. I'm 100% I'm entering the correct password.

         

        After a moment, it displays the message "If you're having a problem entering you password, press and hold the power button on your Mac to shut it down. Then press it again to start up in the Recovery OS." So, I follow these instructions and startup in the Recovery OS.

         

        I'm presented with the following options and I've tried all 3 and nothing helps ...

         

        1 - I forgot my password. (For reasons I can't remember, possibly that I'm an idiot, I didn't store my recovery key in iCloud.)

         

        2 - My password doesn't work when logging in. (For this option, it asks me to enter my password to unlock my boot volume and it works. Then it asks me to select a user to reset the password for, and I select the only user I have defined. it asks me to enter my iCould password and I do. I have 2FA turned on and I enter the activation code. It then asks me to enter a new password. I enter it and I get the following message: "Credentials could not be verified username or password is invalid")

         

        3 - My keyboard isn't working when typing my password to log in. (With this option, I'm prompted to enter my password to disable FileVault. If I enter a wrong password, it shakes no. If I enter my correct password and click Next, a dialog displays asking if I'm sure I want to disable FileVault on my volume. I click the button indicating I do, and it says my volume has been decrypted, but I still can't login!!! I'm still prompted for a password immediately on boot and it doesn't accept the password that I'm 100% sure is correct.)

         

        I've also just booted straight into recovery and I'm able to mount my FIleVault volume in Disk Utility without issue using my password. I ran FirstAid and no problems were detected.

         

        Does anyone have any ideas before I just nuke the whole thing?