14 Replies
      Latest reply on Dec 28, 2016 10:42 PM by johnnysung
      MattOz Level 1 Level 1 (0 points)



        Since 10.12 Sierra major update, I can't compile one of my iOS projects only on device. But weird, it's works fine on simulator.

        So I tried to remove and resetup my dev account in Xcode, hard reboot, remove and resetup all certificates in keychain, etc.

        I use XCode 8.0. I also tried it on Xcode 8.1 beta too, same result.


        The error at end of compilation :


        SecKey API returned: -25304, (null)/Users/***/Library/Developer/Xcode/DerivedData/***-epkppprfmidyatftsvnxgjqsawit/Build/Products/Debug-iphoneos/***.app/Frameworks/libswiftAVFoundation.dylib: unknown error -1=ffffffffffffffff

        error: Task failed with exit 1 signal 0 { /usr/bin/codesign '--force' '--sign' 'C47B52FDE2CABFC81D33BED8937984AF8BC6DC33' '--verbose' '/Users/***/Library/Developer/Xcode/DerivedData/***-epkppprfmidyatftsvnxgjqsawit/Build/Products/Debug-iphoneos/**.app/Frameworks/libswiftAVFoundation.dylib'


        Thank you for any help.