89 Replies
      Latest reply: Feb 28, 2017 1:33 PM by evilBeauty RSS
      ZikPhil Level 1 Level 1 (0 points)

        Hello,

         

        So i've installed the beta 2 on all of my devices, enabled 2 step factor auth etc... etc... Everything seems to be working but when i hit the checkbox to enable the service, i get stuck with a endless 'Turning On...' spiral and it never ends. If i close everything and come back, rehit the 'Allow your Apple Watch to unlock your Mac', i get the turning On... again forever.

         

        Any ideas on how to fix this?

         

        Thanks,

         

        Phil

        • Re: Unable to Activate Auto-Unlock
          dgossage Level 1 Level 1 (5 points)

          I get 'Turning On...' spinning for a while and then the error 'Your Mac was unable to communicate with your Apple Watch.'  Have tried multiple restarts of everything, as well as turning 2FA off and on.

          • Re: Unable to Activate Auto-Unlock
            Tweak Level 1 Level 1 (10 points)

            I have succesful aktivated Auto Unlock, but unlock doesent work. The Apple Watch is on my wrist, unlocked and directly in front of my iMac. Turn the auto unlock option off and on, reboot mac, reboot watch doesent help.

            • Re: Unable to Activate Auto-Unlock
              @Michael@ Level 1 Level 1 (0 points)

              With 2FA enabled and Beta 2 on my mac and Apple Watch When I go to turn on Auto Unlock it just says Turning on... with the endless spinning wheel have tried restarting and nothing has been working so far. Anyone else have any luck?

              • Re: Unable to Activate Auto-Unlock
                Arlo Gilbert Level 1 Level 1 (0 points)

                I am having the exact same experience.

                 

                Apple ID has 2FA not 2FV as required. Watch OS beta 2, Sierra Beta 2, iOS 10 beta 2.

                 

                Spinning wheel to the left, "Unlocking with Apple Watch" shows for a bit then I get a password prompt with no errors. Password works fine.

                 

                The irony that it now takes longer to log in if the auto unlock is activated is not lost on this developer.

                • Re: Unable to Activate Auto-Unlock
                  @Michael@ Level 1 Level 1 (0 points)

                  On my late 2014 IMac 5k 2FA is enabled on iPhone b2 and Mac b2 in the settings the feature will not show in the pane. I have tried logging out of iCloud and back in restarting device etc.

                  • Re: Unable to Activate Auto-Unlock
                    ZikPhil Level 1 Level 1 (0 points)

                    So! Apparently logging off of iCloud on your mac and re-adding it seems to do the trick, you might have to reboot after to get rid of the 'Unable to connect to Apple Watch'. Everything works fine for me in the admin BUT the functionnality itself is not working. Waiting for Beta 3...

                      • Re: Unable to Activate Auto-Unlock
                        tdeb18 Level 1 Level 1 (0 points)

                        That would be strange, as 9to5Mac got it working, they made a video about it.

                         

                        So there's gotta be a fix for this. I've tried so many things. Rebooting my iPhone, Apple Watch and Mac didn't solve the issue. Switching off and on the functionality on my Mac didn't fix it either. Last thing I tried was turning it off, rebooting my Mac and then turn it on again.

                         

                        The thing is, it asks for some kind of pairing code (like you usually would need to pair a Bluetooth device). But I don't think that should happen, does it? Anyway, that message to fill in a pair code goes away after 10 seconds or so, like it automatically paired. Just curious what causes the issue not being able to unlock my Mac. It results in exactly the same as what you've got: it 'searches' but then prompts me with a password input box anyway..

                          • Re: Unable to Activate Auto-Unlock
                            mcsquaredjr Level 1 Level 1 (0 points)

                            I tried everything described in the thread without much luck. I could not get the checkbox in the settings to show up on the latest model of MacBook retina 13" and my watch was untrusted on the appleid. I got it working after unpairing and pairing my watch. After that the checkbox immediately showed up in the settings.

                             

                            Just go to My Watch app, and tap on your watch at the top. Then click info button on the right and select Unpair Apple Watch. Then follow instructions on the screen. Unpairing and pairing, and restoring from backup might take a while, so be patient. It took probably 40 mins for me.

                             

                            After the sync had been complete, the check box magically appreared in the settings and I was able to unlock my laptop without problems. Also my watch finally became a trusted device on the appleid site.

                             

                            Tried it several times, seems to be working so far. I hope it helps.

                        • Re: Unable to Activate Auto-Unlock
                          sunstarfire Level 1 Level 1 (0 points)

                          Just thinking, because I can not test it now.

                           

                          iPhone 6s iOS10 beta 2

                          AppleWatch watchOS3 beta 2

                          MBP Late 13 MacOS sierra beta 2

                           

                          I saw the option for a while after installing on the MBP. Got the spinning wheel, but no functionality, it never went away. Then I "logged out of" iCloud, after that I do not even see the button anymore. 2FV and all that is active, I see all the devices in iCloud...

                           

                          Could it be they have to be in the same WLAN for this to work? Or at least for the setup to work? I can not really test that at work because the WLAN is proxied and all that.... so no idea. How does this work anyway? Bluetooth alone can't be, that is not close enough to work reliably. Must be something else....

                           

                          s.

                          • Re: Unable to Activate Auto-Unlock
                            Metalnodeug Level 1 Level 1 (0 points)

                            Same problem for me with my iMac Late 2013, after updating i see the checkbox and after update my 2 factors security, the box disapear and nothing. I tried ti reboot iPhone, iMac, Watch and disconnect- connect iCloud but nothing. I tried also reinstall the OS and same problem. I think i can wait a version 3 to use this feature

                            • Re: Unable to Activate Auto-Unlock
                              ChooRefundUG Level 1 Level 1 (10 points)

                              for me it's working. Installed beta 2 on all my systems and enabled two-factor as also disabled two-way auth...

                              BUT for me it's only working if i'm not connected to my external (thunderbolt) display... -.-

                               

                              if i have my thunderbolt display connected, it seems like trying to unlock with the watch but then i still need to enter my password...

                               

                              anyone with the same problem or solution to this?

                               

                               

                              thanks much and best regards,

                              Chris

                              • Re: Unable to Activate Auto-Unlock
                                mrenduch Level 1 Level 1 (0 points)

                                Had the same issue on my 2016 rMB. I logged out of iCloud on my computer and then logged back in. Got it to finally set up. Haven't tried to see if it works though yet.

                                • Re: Unable to Activate Auto-Unlock
                                  tompanderson Level 1 Level 1 (0 points)

                                  same thing with  late 2013 mac pro. saya turning on forecer. it works with my mac book.

                                  • Re: Unable to Activate Auto-Unlock
                                    wayazo Level 1 Level 1 (0 points)

                                    I had this feature working right after installing the latest beta on my Retina MB, late 2013. It was fast and working great.   I followed the instructions in the release notes for OSX Sierra current beta to get it up and running.  I tried the auto unlock feature at least a dozen times over the day and it worked just fine.  This morning when I got near my MB, my Apple Watch started pinging me saying it was unlocking my MB even though I hadn't opened the lid.  Then when I did open the lid, auto unlock failed to work.  It tried  (spinning circle, says "unlocking...") then the message and spinning circle disappeared as it reverted back to asking for my password. Password unlocked the MB.  System prefs on the MB shows a check mark next to the auto unlock feature in the General tab.  iPhone watch app shows my apple ID, and I'm using the 2FA per instructions.  It simply refuses to work now.  Rebooting the MB and watch had no effect, nor has logging on and off iCloud on the MB.  Something changed, just not sure what.  If I come up with a workaround, I'll post it.

                                      • Re: Unable to Activate Auto-Unlock
                                        wayazo Level 1 Level 1 (0 points)

                                        IMHO, this feature is just unstable at least on my late 2013 MB.  It began working again last night, then stopped. I changed nothing in between.   I did a fresh install on a blank partition and it still persists. This morning auto lock worked several times and just before typing this message, it did not work.   I cannot find a process that is interfering with auto lock.  

                                      • Re: Unable to Activate Auto-Unlock
                                        Robz1216 Level 1 Level 1 (0 points)

                                        Apple Developer Relations08-Jul-2016 04:40 PM

                                        It needs to be a Mid-2013 or later Mac. Please provide your response or results by updating your bug report. If uploading files, please compress first.

                                        • Re: Unable to Activate Auto-Unlock
                                          JamesDu Level 1 Level 1 (0 points)

                                          The same problem, my mac cannot communiate with my watch.

                                          Macbook Pro 13'' mid-2014, with mac OS sierra public beta 1.

                                          iPhone 6 with iOS 10 developer beta 2.

                                          Apple watch with Watch OS 3 developer beta 2.

                                            • Re: Unable to Activate Auto-Unlock
                                              MikeShear Level 1 Level 1 (0 points)

                                              i got this working this way:

                                               

                                              i noticed that my machine name on the mac I was using was the same as another mac in my network. So I went to manage my Apple ID, and deleted the Mac from my list of approved devices. Then I signed out of iCloud on that Mac, and then renamed my machine name to something uniquen(in the sharing section of settings) and thensigned back into iCloud on the Mac.

                                               

                                              whwninwent to activate the watch...it worked!

                                            • Re: Unable to Activate Auto-Unlock
                                              Prodromosk Level 1 Level 1 (0 points)

                                              I think I have found the problem..

                                              You have to go to your iPhone,

                                              then go to Watch app --> Passcode --> and turn on the "Unlock with iPhone" option.

                                              Now go and enable the service from your mac

                                              • Re: Unable to Activate Auto-Unlock
                                                steveriggins Level 1 Level 1 (10 points)

                                                Just set up b3 (directly from b1) and I got this error.

                                                 

                                                Simply powering off the Apple Watch. booting it, and unlocking it with my iPhone allowed the Mac to connect to it.

                                                 

                                                It doesn't work, but at least the checkbox is on!

                                                • Re: Unable to Activate Auto-Unlock
                                                  leeknight1981 Level 1 Level 1 (0 points)

                                                  Hi i litrally have had all of the Above Issues but i got it to work by 1 Changing the passcode on my apple watch from simple 4 digit and turned off unlock with iPhone on iPhone, 2 Re started apple watch, 3 Re Enabled unlock with iPhone now works Every time Hope this Helps for Everyone

                                                   

                                                  MacBook Pro (Retina, 15-inch, Mid 2014) 1TB 16GB (Sierra 16A270f)

                                                   

                                                  Watch SS 42mm

                                                   

                                                  iPhone 6s Plus 128GB

                                                  • Re: Unable to Activate Auto-Unlock
                                                    ohiocitydave Level 1 Level 1 (0 points)

                                                    I was able to solve the issue by turning off handoff on my MacBook and restarting it followed by turning off handoff in the watch app and restarting the phone. Once they were both up and running, I enabled handoff on the MacBook and then in the Apple Watch app.

                                                     

                                                    When I went back to the Security and Privacy control panel to turn the unlock feature on, it actually took a second for the option to appear. Once it did, however, it worked as soon as I checked the box and put in my Mac password.

                                                     

                                                    Hope this helps!

                                                    • Re: Unable to Activate Auto-Unlock
                                                      g.pederson Level 1 Level 1 (0 points)

                                                      able to get option to show up on early 2013 map retina after upgrading wifi card to BCM94360CSAX for those interested.

                                                      • Re: Unable to Activate Auto-Unlock
                                                        SirDrSpiderpig Level 1 Level 1 (10 points)

                                                        I had similar issue as well.  All my devices were updated to latest version (developer 7 on 10.12).   I would click on the checkbox to activate it and it spun and then after 5-10 minutes would give the error.  I tried signing off from icloud, rebooting, even doing a fresh in stall of the OS - nothing seemed to work.  So after a couple of days I was working on the laptop and casually went to try it again - and bam - it worked.  So not sure why it worked then and not the times earlier.  Either way it's a cool feature.

                                                         

                                                        I wish in the future we'd get the ability to unlock our dekstop Mac's as well.  Maybe not automatically, but once in range we can click something on the watch to unlock it.

                                                          • Re: Unable to Activate Auto-Unlock
                                                            Sourdoughjosh Level 1 Level 1 (0 points)

                                                            I also found that beta 8 seemed to screw up something in the network settings. I was able to get Unlock working again only by both:

                                                             

                                                            1) Reset Network Settings on iPhone (which also resets network settings on watch).

                                                             

                                                            2) Reset the bluetooth module on the Mac (Shift+Option while clicking the bluetooth menu, which will give you access to the Debug menu. Select "Reset the bluetooth module").

                                                             

                                                            Hope that helps someone!

                                                              • Re: Unable to Activate Auto-Unlock
                                                                nortonandreev Level 1 Level 1 (0 points)

                                                                I have literally tried everything and nothing seems to work. I feel disappointed...

                                                                • Re: Unable to Activate Auto-Unlock
                                                                  Random206 Level 1 Level 1 (0 points)

                                                                  Yer I just updated to this version this morning, and I have the latest Developer build for WatchOS3, iOS10.0.1 and macOS Sierra, and for some reason the ability to unlock my mac with my watch was turned off.

                                                                   

                                                                  I tried to turn it on and nothing.

                                                                  Tried:

                                                                  Resetting network settings and bluetooth - no go

                                                                  Signing out and back in to iCloud - no go

                                                                  Restarting mac - no go

                                                                  Restarting watch - no go

                                                                  Failing reinstalling macOS or resetting the watch, nothing has worked so far.

                                                                   

                                                                  Hopefully I'll be able to get it working tomorrow as another person stated they were able to get it working a few days later.

                                                                   

                                                                  Wish me luck!

                                                              • Re: Unable to Activate Auto-Unlock
                                                                rollmastr Level 1 Level 1 (0 points)

                                                                13" MBP Early 2015 + Sierra GM

                                                                42mm stainless watch + Watch OS 3 GM

                                                                iPhone 5S + iOS 10 GM

                                                                 

                                                                I keep getting the error "Your Mac was unable to communicate with your Apple Watch"

                                                                 

                                                                2FA is enabled, handoff works, with a locked watch I get the error message that I should unlock my watch and retry, so the devices do seem to communicate.

                                                                 

                                                                I tried pretty much everything mentioned here. Created a new user account on my mac, signed off and on to iCloud on all devices, unpaired and repaired my watch, even set it up as a new watch instead of restoring from backup. Turning handoff off and on again, disabling FileVault nothing worked for me so far.

                                                                 

                                                                /edit: I also reset Bluetooth on my Mac and cleared my iPhone network settings. No go.

                                                                  • Re: Unable to Activate Auto-Unlock
                                                                    eggroid Level 1 Level 1 (0 points)

                                                                    I'll second this. I've tried everything here, rebooted everything, signed out of iCloud on everything. Nothing.

                                                                     

                                                                    12" Macbook Sierra GM

                                                                    iPhone 6+

                                                                    42mm stainless watch + Watch OS 3 GM

                                                                    • Re: Unable to Activate Auto-Unlock
                                                                      zahirw Level 1 Level 1 (0 points)

                                                                      I had an iPhone 6s and when I shifted to an iPhone 7, unlcoking my MBP 2015 with my Apple Watch 2 stopped working. The final fix was :

                                                                      1. Unpair Apple Watch
                                                                      2. Re-Pair Apple Watch
                                                                      3. Sign out of iCloud on MBP
                                                                      4. Sign in to iCloud on MBP
                                                                      5. Check box to unlcok using Apple Watch on MBP under System Preferences > Security & Privacy

                                                                       

                                                                      Worked at the first go

                                                                    • Re: Unable to Activate Auto-Unlock
                                                                      Kydosan Level 1 Level 1 (0 points)

                                                                      I hit this problem too, and managed to sort it out after a fairly significant amount of screwing around and reaching dead ends.

                                                                       

                                                                      I'm assuming what went screwy for me was that I had to enable 2FA before enabling the option, which went smoothly and authenticated my Macbook, but there's no prompt to authenticate the phone, it wasn't until I went into Settings > iCloud on my phone and waited 10 seconds or so that I was prompted to authenticate it with a code (which was then sent to my Macbook) Once I authenticated the phone I went into the settings in my watch app to check everything looked fine, and then restarted my watch (probably not necessary, but I did it anyway) and once it started back up, unlocking via the watch started working.

                                                                       

                                                                      If you've turned on/toggled 2FA and haven't authenticated both your phone and your computer, go into the iCloud settings on each and enter the codes from the other when prompted. My guess is this problem is happening for at least some of you because you've recently turned on 2FA to use it, but haven't yet been through the 2FA song and dance on your phone, since only your Mac will have prompted you do it at the time.

                                                                       

                                                                      Some of you seem to have taken desperate measures though, I guess you guys are out of luck until the 20th :/

                                                                      • Re: Unable to Activate Auto-Unlock
                                                                        Vishae Level 1 Level 1 (0 points)

                                                                        Mine was flaky until the official macOS sierra and iOS 10 came out, then it was working brilliantly.

                                                                         

                                                                        Then my iPhone 7 arrived, I set up my new iPhone with a backup from my previous phone and since then the auto-unlock no longer works.

                                                                         

                                                                        I turned off "Allow your Apple Watch to unlock your Mac" and tried to turn it back on, but it gives me the "cannot connect to Apple Watch" error message.

                                                                         

                                                                        This is very frustrating.

                                                                        • Re: Unable to Activate Auto-Unlock
                                                                          shy_shocker Level 1 Level 1 (0 points)

                                                                          1. Unpaired the watch and paired it agian.

                                                                          2. Logged out of iCloud on my computer and then logged back in.

                                                                          3. Turned on "Allow your Apple Watch to unlock your Mac"

                                                                          4 It works now

                                                                            • Re: Unable to Activate Auto-Unlock
                                                                              Lito Level 1 Level 1 (0 points)

                                                                              does not show on my conI have tried everything, and I mean ALL of the above and still nothing.

                                                                               

                                                                              I know I followed each and every step.

                                                                              Unpaired and paired teh watch.

                                                                              Logged out of iCloud on my computer (and even the phone!) and then logged back in.

                                                                               

                                                                              Nothoing. "Allow your Apple Watch to unlock your Mac" does not show at all.

                                                                               

                                                                              I am using the lates as of today release of all OSs.

                                                                               

                                                                              HELP! PLEASE!!!

                                                                            • Re: Unable to Activate Auto-Unlock
                                                                              benhomey Level 1 Level 1 (0 points)

                                                                              There were 2 things that wasn't mentioned here (or anywhere else!) that resolved this problem:

                                                                               

                                                                              1. Turn on 'Back To My Mac' in System Preferences > iCloud

                                                                              2. If you have other routers in the house running as "extenders", turn them off. Just leave only your main router running.

                                                                               

                                                                              Best regards,

                                                                              Ben

                                                                                • Re: Unable to Activate Auto-Unlock
                                                                                  SendMe Level 1 Level 1 (0 points)

                                                                                  Had same problem. I tried everything in this trail. In the end, Unpairing and Pairing again (long wait), fixed it. Apple Watch is still syncing / installing Apps from backup. However, after ALL that trouble, it's faster to type in my long password than what it takes Apple Watch to unlock the screen on its own. Bummer. Ended up the same as third party software out there a while ago.

                                                                                    • Re: Unable to Activate Auto-Unlock
                                                                                      nadimc Level 1 Level 1 (0 points)

                                                                                      I had the same issue with my iMac while my Macbook had no problem unlocking with the Apple Watch. My solution was to disable WiFi sharing on the iMac and it worked afterwards. It turns out you need both Bluetooth and WiFi enabled before the automatic unlock can work.

                                                                                  • Re: Unable to Activate Auto-Unlock
                                                                                    GrayOwl Level 1 Level 1 (0 points)

                                                                                    Guys the watch has to be on your wrist to work. Was having the same issue because i kept pluging it in to an outlet while activiating the setting.

                                                                                    • Re: Unable to Activate Auto-Unlock
                                                                                      capchuckprice Level 1 Level 1 (0 points)

                                                                                      I found that by turning off Automatic Login (in Users and Groups), the feature worked. None of the other suggestions in this thread worked.

                                                                                      • Re: Unable to Activate Auto-Unlock
                                                                                        mallchin Level 1 Level 1 (0 points)

                                                                                        I'm running the final release not beta but having the same issue.

                                                                                         

                                                                                        For Auto Unlock to work the devices need to be able to talk via bluetooth and Wi-Fi.  I fixed it by making sure all of these were turned on and all devices were connected to the same Wi-Fi network.

                                                                                         

                                                                                        Also, if your Wi-Fi router supports multiple bands (2.4Ghz, 5Ghz) ensure all devices are using the same band.

                                                                                        • Re: Unable to Activate Auto-Unlock
                                                                                          vrsantana Level 1 Level 1 (0 points)

                                                                                          To be clear: If on your apple watch app from your iphone you toggle handoff off and then back on it should work.  I was having this same issue but it was unclear from all these posts on where I should be turning off and on Handoff.  Turns out I decided to try doing the same thing on the watch app.  It worked!!

                                                                                          • Re: Unable to Activate Auto-Unlock
                                                                                            saturn Level 1 Level 1 (0 points)

                                                                                            have you figured out this issue? i have the same one

                                                                                            • Re: Unable to Activate Auto-Unlock
                                                                                              Ohana3ps Level 1 Level 1 (0 points)

                                                                                              After reading various replies to your post, I followed several options, but the one thing that worked for me was to check my iCloud settings on my phone (using a restored image of Beta after upgrade from iphone 6 to 7 plus.)  My watch had previously worked just fine to unlock my MacBook Air... same o/s was simply restored on the new phone.

                                                                                               

                                                                                              Issue was under Settings-iCloud-Keychain, Find My iPhone and iCloud Backup, were all set to "Off."  Tried to enable only Keychain on, but would not hold setting.  Would turn on, but then off when backed out.  Once Enabled all 3 settings, then they held in "On" position. 

                                                                                               

                                                                                              Went back to MacBook Air settings, Security, checked the "Allow Apple Watch to Unlock Mac," and BOOM!  It popped right on, without issue. Then tested unlock and working flawlessly, as before.

                                                                                               

                                                                                              Long story short, your issue may have to do with iCloud security settings, which makes sense, since this is a shared pool of security settings.

                                                                                              • Re: Unable to Activate Auto-Unlock
                                                                                                evilBeauty Level 1 Level 1 (0 points)

                                                                                                I have the same issues and logging out my AppleID on Mac and logging back in solved it for me. Hope it can help!