18 Replies
      Latest reply on Apr 11, 2017 10:57 AM by dmueller39
      SaulE Level 1 Level 1 (0 points)

        I'm trying to get universal links working for my app but it's becoming painfully frustrating.


        I have created my unsigned apple-app-site-association file and uploaded to my web. Therefore, I have run the App Search API Validator (https://search.developer.apple.com/appsearch-validation-tool/) and Universal Links element's status appears as "RECOMMENDED", but I'm not getting any reason why the status isn't "PASSED".


        Previously I was getting the following message: "The apple-app-site-association file was found but it doesn't follow the required format.", but not anymore.


        The file is not signed but as I read in other posts, it's no longer needed to sign it.

        • Re: Get universal links working
          pdm Apple Staff Apple Staff (1,770 points)

          The "doesn't follow the required format" indicates that the file was invalid, probably invalid JSON.  Did you change something in it?  What's the domain where it's hosted? 

            • Re: Get universal links working
              SaulE Level 1 Level 1 (0 points)

              I tried to be sure that it was written in plain text and then it stopped giving the message. As I replied to yudi, my website didn't pass Smart App Banner and Deep Links tests, I don't know if that could be a problem.


              The domain is "https://www.timp.pro".

              • Re: Get universal links working
                SaulE Level 1 Level 1 (0 points)

                I made changes on the website to support the Smart App Banner and now Smart App Banner, Deep Links and Universal Links are passed, though Deep Links shows this message: "All deep links redirect to the same URL.".


                Nonetheless, when I enter my website no banner appears and, if I tap a link to my website from a mail in "Mail" app, the app doesn't open despite I did the required changes on the app (added the "applinks" entitlements to the project and added "- (BOOL)application:(UIApplication *)application continueUserActivity:(NSUserActivity *)userActivity restorationHandler:(void(^)(NSArray *restorableObjects))restorationHandler" method to my AppDelegate).

              • Re: Get universal links working
                yudi Level 1 Level 1 (0 points)

                this is beacuse you dont have smart banner enabled OR you do but you didn't supply the app-argument in the meta tag

                • Re: Get universal links working
                  avneesh84 Level 1 Level 1 (0 points)


                  I am also facing the same issue with the universal link. For me also Deep Links is failing and everything else is successful.

                  So my question is for implementing universal link do i mandatorily need to implement the smart banners.

                  This is not documented anywhere so am not sure if i need to implement this or not?

                  I have posted more details regarding my domain and everything in another question.




                    • Re: Get universal links working
                      juanPa Level 1 Level 1 (0 points)

                      I am having the same problem.  We configured Universal Links and they pass the branch validator, but the apple validator says:


                      Deep Link


                      ACTION REQUIRED

                      • Could not extract required information for deep links. Learn how to implement the recommendedUniversal Links.
                        • Re: Get universal links working
                          eskimo Apple Staff Apple Staff (13,905 points)

                          What’s the name of your site?

                          Share and Enjoy

                          Quinn “The Eskimo!”
                          Apple Developer Relations, Developer Technical Support, Core OS/Hardware
                          let myEmail = "eskimo" + "1" + "@apple.com"

                            • Re: Get universal links working
                              peymanmo Level 1 Level 1 (0 points)

                              I'm having the same problem. I'm testing it on: https://893d9220.ngrok.io

                              by the time you open it, it's probably going to be dead.

                              but here is the result of my curl:


                              *   Trying

                              * Connected to 893d9220.ngrok.io ( port 443 (#0)

                              * TLS 1.2 connection using TLS_ECDHE_RSA_WITH_AES_128_GCM_SHA256

                              * Server certificate: *.ngrok.io

                              * Server certificate: RapidSSL SHA256 CA - G3

                              * Server certificate: GeoTrust Global CA

                              > GET /apple-app-site-association HTTP/1.1

                              > Host: 893d9220.ngrok.io

                              > User-Agent: curl/7.43.0

                              > Accept: */


                              * HTTP 1.0, assume close after body

                              < HTTP/1.0 200 OK

                              < Server: SimpleHTTP/0.6 Python/2.7.10

                              < Date: Wed, 22 Jun 2016 21:05:05 GMT

                              < Content-type: application/json

                              < Content-Length: 211

                              < Last-Modified: Wed, 22 Jun 2016 21:02:27 GMT

                              * HTTP/1.0 connection set to keep alive!

                              < Connection: keep-alive



                                  "applinks": {

                                      "apps": [],

                                      "details": [


                                              "appID": "<prefix>.<bundleid>",

                                              "paths": [ "/ios9" ]





                              * Connection #0 to host 893d9220.ngrok.io left intact

                              • Re: Get universal links working
                                dtarcode Level 1 Level 1 (0 points)

                                I'm also getting "Could not extract required information for deep links" using the Universal Link validator. What's odd is that it passed when we uploaded the file in April and the file hasn't changed since then...it just stopped validating. And whatever the issue is, appears to break Universal Links on iOS 9 too. Both our app and the validator were working fine as of June 1st.


                                Website is webprotectme.com. Thank you in advance for your advice.

                                • Re: Get universal links working
                                  Mr. Parikh Level 1 Level 1 (0 points)

                                  What should I do to resolve this issue? I am not able to pass the validation.

                                  Please help with this issue.

                                  Deep Links


                                  ACTION REQUIRED

                                • Re: Get universal links working
                                  Mr. Parikh Level 1 Level 1 (0 points)

                                  I have exactly same problem and I have tried all except the sign in of the text file named "apple-app-site-association".

                                  Any help will be appriciated.
                                  Does any one able to find out any way to make it working?

                              • Re: Get universal links working
                                dmueller39 Level 1 Level 1 (0 points)

                                For anyone else who comes here, a great tool for validating your apple-app-site-association file is https://jsonformatter.curiousconcept.com/

                                Make sure you plug the url for that file https://[your domain here]/.well-known/apple-app-site-association into the field, and it will quickly tell you if:


                                - The json is 100% valid

                                - The mime type is correct


                                Also, if you are testing BEFORE you release, you will get this message:

                                • Error no apps with domain entitlements
                                • The entitlement data used to verify deep link dual authentication is from the current released version of your app. This data may take 48 hours to update.

                                Which should really read "no apps in app store with domain entitlements"


                                The small piece you still need to do manually is making sure the file is served via 200, instead of a redirect.